amd64/177240: zpool import failed with state UNAVAIL but all disks are ONLINE

Elliot cccfanta at
Fri Mar 22 17:50:00 UTC 2013

>Number:         177240
>Category:       amd64
>Synopsis:       zpool import failed with state UNAVAIL but all disks are ONLINE
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    freebsd-amd64
>State:          open
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Fri Mar 22 17:50:00 UTC 2013
>Originator:     Elliot
FreeBSD 9.1 amd64 (custom build)

I’ve been googling but can’t find a solution for my problem with “zpool import” .  My system was just upgraded to FreeBSD 9.1 for 1-2 weeks. It suddenly hanged, so I boot the system with a Live CD (FreeBSD 9.1 with ZPOOL version 28) and tried to do zpool import but failed.

All the disks are showing ONLINE but the zpool is showing UNAVAIL with “newer version” error. But the “zdb -l” show on disk format version 14. ZPOOL version 28 is the latest version FreeBSD is using. Do you know what went wrong with the zpool? Is it possible a software bug that corrupted the pool data? I’ve also tried “zpool import -fFX tank” but still couldn’t help.

# zpool import
pool: tank
id: [removed]
state: UNAVAIL
status: The pool was last accessed by another system.
action: The pool cannot be imported due to damaged devices or data.

tank UNAVAIL newer version
mirror-0 ONLINE
label/disk0 ONLINE
label/disk1 ONLINE

# zpool import -fFX tank
cannot import ‘tank’: one or more devices is currently unavailable



More information about the freebsd-amd64 mailing list