amd64/171355: FreeBSD 9.1rc1 (and 10-HEAD) not booting on HP Pavilion g6 2147sl

John Baldwin jhb at
Thu Sep 6 21:11:21 UTC 2012

On Wednesday, September 05, 2012 4:14:48 pm Stefano Marinelli wrote:
> >Number:         171355
> >Category:       amd64
> >Synopsis:       FreeBSD 9.1rc1 (and 10-HEAD) not booting on HP Pavilion g6 
> >Confidential:   no
> >Severity:       non-critical
> >Priority:       low
> >Responsible:    freebsd-amd64
> >State:          open
> >Quarter:        
> >Keywords:       
> >Date-Required:
> >Class:          sw-bug
> >Submitter-Id:   current-users
> >Arrival-Date:   Wed Sep 05 20:20:03 UTC 2012
> >Closed-Date:
> >Last-Modified:
> >Originator:     Stefano Marinelli
> >Release:        9.1-rc1
> >Organization:
> >Environment:
> impossible to obtain - machine stops at boot
> >Description:
> Hi,
> I tried to install FreeBSD 9.1-rc1 (amd64 and i386, no difference) on the HP 
Pavilion g6 2147sl. The installation disk's loader runs, the kernel starts to 
boot then hangs. No strange messages come out (even with verbose output turned 
on) and the boot process stops there. Everything seems to be recognised in a 
proper way (usb3, ahci, re0 network card, etc).
> I've done some tests (thanks to the suggestions on the ##freebsd irc 
channel's people) but no success and no further information to add. I can't 
even go to ddb. But if I remove the cd from the tray, the status change gets 
detected and the kernel prints something on the screen.
> 9.0 can boot, but it's almost unusable as both the re0 and the wifi 
interface aren't detected and there isn't any support for power management so 
fans are running all the time.
> It seems to stop after USB recognition. But I guess it's already finished> 
with usb...

Does 9.1 fail to recognize the on-board disk?  I've seen several reports of 
9.1 failing to discover certain SSD's but working ok with spinning disks on 
IBM laptops where 9.0 worked fine.

John Baldwin

More information about the freebsd-amd64 mailing list