amd64/170677: FreeBSD 9.x does not boot if 2 hard disks are on system

Harald von Fellenberg productnews at
Thu Aug 16 19:40:12 UTC 2012

>Number:         170677
>Category:       amd64
>Synopsis:       FreeBSD 9.x does not boot if 2 hard disks are on system
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    freebsd-amd64
>State:          open
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Thu Aug 16 19:40:11 UTC 2012
>Originator:     Harald von Fellenberg
>Release:        FreeBSD 9.1-BETA1
FreeBSD 9.1-BETA1 FreeBSD 9.1-BETA1 #0: Thu Jul 12 09:38:51 UTC 2012 root at amd64
FreeBSD 9.x does not boot on AMD64 system (16GB mem) when 2 hard disks are present, but boots if second disk is removed. 
I tried FreeBSD 9.1-BETA1 and, earlier, PCBSD 9.0-RELEASE and PCBSD 9.0-STABLE-20120524 (all 64 bit). The behaviour is similar.

Hardware configuration:
Motherboard: GA-Z68X-UD3H-B3(rev. 1.0)
BIOS version: F9

CPU: Intel i5 2500K (3300) Quad Core
CPU frequency: 3300 MHz

Memory: 16 GB, Kingston DDR3-SDRAM 1333 MHz

Harddisks: 2 Western Digital  WDC WD10EALX-009BA0 1 TB (SATA)


Graphics card: ASUS Nvidia GeForce ENGTX550 Ti DC DI

Power Supply: 550 W

BIOS Parameters (only the interesting ones)

BIOS Version F9
EFI CD/DVD boot option AUTO
PCH SATA control mode  AHCI
SATA Port 0-3 native mode ENABLED
GSATA3 controller ENABLED

System Behaviour:
I bought the system in November 2011 with one HD and one DVD R/W.
I run this in a multi-boot configuration with Windows-7,
Ubuntu 10.04 (lucid lynx), Debian (squeeze), PCBSD 9.0 (FreeBSD based).
Everything worked fine.

Last month I added a second HD (identical type to first HD).
Installation details see above.
Windows-7, Ubuntu, and Debian worked as expected. But FreeBSD and PCBSD do not
start properly. I get the following display:

BTX loader 1.00 BTX version is 1.02
Console: internal video/keyboard
BIOS drive C: is disk 0
BIOS drive D: is disk 1

The vertical bar | shows usually the "spinner", a rapid
sequence of | / - \ giving the user the impression ot a spinnign wheel,
until the loader prompt is displayed and the boot process continues.

In my case, the "spinner" does not spin, but remains quiet or advances
a few times in a multi-second interval until coming to  complete stop.
This behaviour is the same for all the different SCSI and BIOS
configurations that I have tried.
The same behaviour occurs for booting PCBSD 9.x from HD, from DVD, and from
USB stick. FreeBSD 9.1-BETA1 boots from CD and can be installed on HD, but the installed system then gets stuck like shown.
In other words, FreeBSD cannot be run.

I assume that it is the bootstrap loader that poses a problem.

the second disk has been unplugged (power and/or SATA), then both PCBSD and FreeBSD can be booted and run from the first HD. After pluggin in the second disk, booting FreeBSD and PCBSD fails.


More information about the freebsd-amd64 mailing list