amd64/148002: panic / page fault while booting from install dvd on asrock 939-dual sata

Mike dura-zell at
Sat Jun 19 23:50:02 UTC 2010

>Number:         148002
>Category:       amd64
>Synopsis:       panic / page fault while booting from install dvd on asrock 939-dual sata
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    freebsd-amd64
>State:          open
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Sat Jun 19 23:50:01 UTC 2010
>Originator:     Mike
>Release:        8.0-Release
unable to do, machine doesn't boot
I downloaded the dvd from one of the ftp mirrors, burned it and tried to boot from it. Right after harddisk detection the kernel panics like this:

fatal trap 12: page fault while in kernel mode
cpuid = 0; apic id = 00
fault = virtual address         = 0x0
fault code = supervisor read, page not present
instruction pointer             = 0x20:0x0
stack pointer                   = 0x28:0xe5b64b68
frame pointer                   = 0x28:0xe5b64b9c
code segment                    = base 0x0, limit 0xfffff, type 0x1b
                                = DPL 0, pres 1, def32 1, gran 1
processor iflags                = interrupt enabled, resume, IOPL = 0
current process                 = 4 (g_down)
trap number                     = 12
panic: page fault
cpuid = 0
Uptime: 2s

Mainboard: ASRock 939Dual-SATA2
CPU: AMD Athlon 64 (2GHz)
RAM: 2GBytes DDR400
Video Card: nVida Gefroce 7300GS
HDD: 2 Sata150 Disks, connected to the SATA connectors on the board. SATA2 is disabled.

Tried to deactivate ACPI, set kern.smp.disabled from loaderprompt, both didn't help. 
Tried to boot i386 dvd instead of i386-64: didn't work either with the same panic. 
Tried FreeBSD 7.2/i386: booted cleanly, was able to install.

Get this very hardware, try to boot with FreeBSD 8.0 => crash


More information about the freebsd-amd64 mailing list