amd64/147926: system freezes due to heavy io to the disks

Andriy Gapon avg at
Sat Jun 19 08:00:11 UTC 2010

The following reply was made to PR amd64/147926; it has been noted by GNATS.

From: Andriy Gapon <avg at>
To: Dominic Duklas <dodo1122 at>
Cc: bug-followup at
Subject: Re: amd64/147926: system freezes due to heavy io to the disks
Date: Sat, 19 Jun 2010 10:55:22 +0300

 on 17/06/2010 03:36 Dominic Duklas said the following:
 >> Number:         147926
 >> Category:       amd64
 >> Synopsis:       system freezes due to heavy io to the disks
 >> Confidential:   no
 >> Severity:       non-critical
 >> Priority:       low
 >> Responsible:    freebsd-amd64
 >> State:          open
 >> Quarter:        
 >> Keywords:       
 >> Date-Required:
 >> Class:          sw-bug
 >> Submitter-Id:   current-users
 >> Arrival-Date:   Thu Jun 17 00:40:00 UTC 2010
 >> Closed-Date:
 >> Last-Modified:
 >> Originator:     Dominic Duklas
 >> Release:        9.0-CURRENT
 >> Organization:
 >> Environment:
 > FreeBSD lain 9.0-CURRENT FreeBSD 9.0-CURRENT #2 r209225: Wed Jun 16 01:47:01 BST 2010 root at lain:/usr/obj/usr/src/sys/LAIN amd64
 >> Description:
 > I'm currently running freebsd on my desktop (core i7 920, 6gb of ram). Since around January I'm having problems with the system freezing for short periods of time and eventually locking up due to heavy reads/writes to the disk. 
 > The cursor would freeze for a split second and songs in my music player (quodlibet) would skip completely (the error logs say that the music player was unable to access the song which was currently playing, even though my music collection is on a completely different hard drive than the os). 
 > After 10-20 minutes of the occasional freezes (the frequency is random, sometimes it can go without any freeze for some minutes or it can freeze many times in a short period of time) the system locks up completely and reboots itself. There is no crash dump produced by the kernel, nor anything shows in dmesg when the short freezes occur. 
 > I tried putting freebsd on a different hard drive, changing filesystems from zfs which I currently use to ufs but the issue doesn't go away. 
 > Today I tried using the geom rr sched which was recently committed to current to see whether it would make a difference, but it didn't help.
 > This issue is not related to swapping as ram usage never gets high enough, and is also not directly caused by heavy cpu usage, although it might be part of the problem.
 > I've done several clean installs of freebsd current since the issue first appeared.
 >> How-To-Repeat:
 > make -j8 buildworld would trigger it in my case, or 2 simultaneous while loops with extracting a large file archive or compiling something big like openoffice/gcc/boost from ports.
 >> Fix:
 You haven't let us know some important details.
 What disk controller do you have?
 What driver do you use for it (if there are multiple choices)?
 P.S. Why did you file this bug under amd64 category?  Have you tested how i386
 version of FreeBSD works on the same machine and came to conclusion that it's
 only amd64 version that is affected?
 Andriy Gapon

More information about the freebsd-amd64 mailing list