amd64/141060: Can't install 8.0-RELEASE on the server where 7.2 works fine

Michael Sinatra michael at
Tue Dec 1 19:13:47 UTC 2009

On 12/01/09 09:27, Konstantin Belov wrote:

> Can not install 8.0-RELEASE on the server where 7.2 were installed
> successfully. After creating fdisk slices and FSs the installator
> tries to do newfs and says "Can not find device node /dev/aacd0s1a"
> (but it just was created). Tried to install not on the ARRAY, but on
> SATA HDD attached directrly to motherboard controller, but had the
> same message. Configuration: M/B Supermicro X7DBE-X, Intel X5410,
> Adaptec 2820SA (PCI-X).
> Next: Tried to upgrade successfully installed 7.2 to 8.0. After
> rebooting with new kernel it can not find root FS and I can not find
> it too in the list of possible mount devices (i.e. no aacd0s1a, just
> aacd0a). But entering to the loader prompt and making lsdev shows all
> FSs and SWAP on the disk where it was created (disk D).
>> How-To-Repeat:
> Try to install on the specefied configuration.
>> Fix:
> Could not do anything. Finally leave 7.2 version on the server. Hope
> I'm not alone with such a trouble and you will find the problem and
> make a fix.

There may be stale BSD disklabels from an older version on the disks.
Assuming you want to completely wipe out your 7.2 installation, you may
need to dd a bunch of zeros onto the first few sectors of the disk so
that 8.0 can properly re-create the partition.

If you do want to keep the existing partitions, then you may be able to do:

dd if=/dev/zero of=/dev/aacd0s1a bs=512 count=1 seek=1

That has usually solved my 7.2 -> 8.0 issues that have the same symptoms
as you're describing.

BE CAREFUL and make sure you have backups of everything you want to save!

Note that this is related to the switch from GEOM_PART_BSD to
GEOM_PART_GPT in the kernel.  You could also build a custom kernel with
GEOM_PART_BSD instead of GEOM_PART_GPT, but my understanding is that
support for the former will go away soon.


More information about the freebsd-amd64 mailing list