[regression] 8.0-CURRENT amd64: SATA disks not attaching, MCP55 controller

Sticky Bit stickybit at gmx.net
Thu Aug 6 18:22:24 UTC 2009

On Thu August 6 2009 09:28:58 Florian Smeets wrote:

> i had the same problem with MCP55 on amd64, i tried the new ahci module
> but to no avail.
> However if you set hw.pci.mcfg=0 the disks are found by the normal ata

Thanks for the hint!

I tried it again with 'set hw.pci.mcfg=0' from boot loader prompt and now it 
actually finds and attaches the disks as usual.

But I do not know if I need 'support for PCI-e memory mapped config access', 
where it is needed and if it can cause problems later with an RELENG_8 
installation if it is disabled like in RELENG_7.

I only have one PCIe device, a PCIe graphics card, which is working well with 
drm.ko / radeon.ko modules and radeonhd driver under RELENG_7.

Is it safe to stay with 'hw.pci.mcfg=0' under RELENG_8 for the future?

And if so, should the default setting be changed from enabled to disabled for 
8.0-RELEASE if it is not yet mature enough and the cause of problems? Looks 
like several people are affected by this regression.


More information about the freebsd-amd64 mailing list