Can't install FreeBSD amd64 (intel DP45SG)

Mark Stapper stark at
Wed Aug 5 06:38:27 UTC 2009

Dear David,

In the loader menu, are you able to drop to the loader prompt, and view
your hard-disk(s) using:
lsdev [-v]

Lists all of the devices from which it may be possible to load modules.
If -v is specified, more details are printed.

If so, you might be able to do a manual install using a i386 livefs
("rescue") disk. You would need both the i386 livefs and a amd64 install
medium though(either usb/cdrom or whatever).
You said you tried pxeboot, I assume u have another machine at your
disposal. You could use that do do a manual install as well(if it runs a
system which supports UFS, like freebsd ;-), if not, a VM is your friend).
Another option would be to get a disc image of a freebsd base-install
(shouldn't be more then 300mb).
All this assuming you are able to boot the generic kernel of course...
If you are going the manual install way, you might as well build your
custom kernel. Since the kernel included in the install cd's doesn't
really work for you anyway.
To summarize your best options are probably:
1. Try a manual install using a i386 livefs cd and a amd64 install medium.
2. Use another system to install the base system and put that in the
problematic one. Either with or without building your own kernel.

I would say the second option, and building your own kernel is your best
Hope it helps.
David Peall wrote:
> Hi
> I tried freebsd-stable but since the machine has not got a problem loading sysinstall with the i386 release I'm posting it here.
> I have a new box here a Intel DP45SG and a Quad core Intel with 4GB ram that I would like to install FreeBSD on.
> I've tried booting with 7.0, 7.1, 7.2 and 8-BETA2 amd64 and all get stuck on:
> 	Trying to mount root from ufs:/dev/md0
> 6.3 and 6.4 will boot into sysinstall but not network card detected.
> By stuck I mean can't scroll lock, caps lock or num lock.  There is no activity even if left for hours.
> I've tried from CD/DVD and pxeboot.
> I found the following:
> Which suggests disabling USB2 I don't seem to have that bios option and tried disabling USB completely, but still no joy. (also leaves me without a keyboard ;-) 
> There are no PATA ports for me to mount an older cdrom and there are only USB ports on the motherboard. There is also no floppy connector or floppy drive.  I'm a bit stuck as to how I should proceed, any ideas welcome.
> Kind regards
> --
> David Peall 
> _______________________________________________
> freebsd-amd64 at mailing list
> To unsubscribe, send any mail to "freebsd-amd64-unsubscribe at"

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 259 bytes
Desc: OpenPGP digital signature
Url :

More information about the freebsd-amd64 mailing list