Semi-working patch for amd64 suspend/resume

Jung-uk Kim jkim at
Wed Oct 22 20:23:19 UTC 2008

On Wednesday 22 October 2008 03:03 pm, Alexander Motin wrote:
> Hi.
> Jung-uk Kim wrote:
> > I was working on suspend/resume support for amd64 and this is the
> > result.  It works with a modified QEMU (QEMU does not support S3)
> > but real boxes that I have don't seem to like it (e.g., broken
> > BIOSes). If there is someone interested in finishing it off or
> > giving it a try, the patch is here:
> >
> >
> I have tried it on my Acer TM6292. S1/S2 are unsupported. On S3
> system successfully got down, but on wakeup button, two seconds
> after power up, even without video initialization, it shut down,
> reset and then started usual boot. I have tried both original and
> updated BIOS, without any difference.
> Can I give you any other help?

When you do 'sysctl debug.acpi.suspend_bounce=1' and 'acpiconf -s 3', 
does it bounce back?  If it does not, there are other problems, e.g., 
device drivers.  On my desktop, for example, vga(4) tries to restore 
previous state while resuming but it hangs system.  In fact, I 
believe ISA-era EGA/VGA save/restore routines do not work for modern 
graphics cards at all. :-(

Jung-uk Kim

More information about the freebsd-amd64 mailing list