7.0-STABLE hanging while running Xorg with nv driver

mdh mdh_lists at yahoo.com
Fri Mar 21 02:51:38 UTC 2008

I posted to -questions earlier, but didn't get any
response and was hoping that maybe someone here would
have some more insight into how I might go about
fixing this problem.  

I recently upgraded a system to 7.0/amd64 from 6.2.
More accurately, I freshly installed 7.0-R on it, then
csup'd to -STABLE.  This system worked fine using
nvidia.com's Xorg drivers with Xorg 6 on 6.2, and
after installing 7.0 and building -STABLE, things
seemed to be going well also.  Once I started Xorg
with kdm/KDE however, the system would (usually within
1-5 minutes after logging in) hang.  I tried gdm/gnome
with the same results.  This was using the nv driver
that was included with the system.  The hang would
occur after some level of activity had occured - once
during openoffice startup, once during seamonkey
startup, once after opening and then closing KDE's
control center and then opening an xterm... The exact
symptom was that the system (including network stack)
would hang - I couldn't ssh to it, or ping it, or even
toggle the caps lock/num lock LEDs on the keyboard. 
The mouse cursor was, however, still responsive on the
screen.  I found this very strange.  It's a USB mouse.
 Unfortunately because it hangs in this way, I can't
get a meaningful dump or anything of that sort.  
My next step was to start Xorg using the vga driver. 
I was unable to reproduce the hang using the vga
driver, however the max resolution and depth is of
course unbearable for even short-term use.  ;)  This
leads me to believe that the issue may be with the nv
driver.  I'm also getting an error out of Xorg, which
you can see in the attached xorg_err.txt file.  I also
have suspicions towards how acpi assigns the
interrupts and such to the video controller.  The
video controller is a GeForce 6200 in the PCIEx16
slot.  I have tried to start without acpi (both
turning it off in the bios and instructing FreeBSD's
boot loader not to load it, however it seems that
FreeBSD can't find anything without acpi now - it
couldn't mount root, or do other useful things.)

A few things that changed between my old build and my
current system...
* 7.0 seems to support (or more fully support) this
system's ACPI.  It's an nvidia nf4u chipset.  The
support was either non-existent or very limited in
* I was using i386 before, but went to amd64 with 7.0.
* I'm using the nv driver for Xorg instead of the ones
from nvidia.com, since nvidia doesn't provide one for
* Xorg 6 -> Xorg 7, and all other software up

No hardware has changed.  

Thank you for any help you can provide.  - mdh

Looking for last minute shopping deals?  
Find them fast with Yahoo! Search.  http://tools.search.yahoo.com/newsearch/category.php?category=shopping

More information about the freebsd-amd64 mailing list