SMP system not running SMP

Freddie Cash fcash at
Wed Jun 28 15:40:36 UTC 2006

On Tue, June 27, 2006 10:07 pm, Ken Gunderson wrote:
> On Tue, 27 Jun 2006 15:06:51 +0100
> Pete French <petefrench at> wrote:
>>> Sun Fire X4100 dual opteron, Adaptec 2230 SLP PCI-X card attached
>>> to 14-disk U320 disk array.  FreeBSD 6.0-REL.  Running non-stop
>>> since January as a busy postgresql server.  I'm buying another one
>>> this week since they're so stable.

>> Whats the motherboard and chipset ? The problem only seems to
>> happen on those 8111 / 8131 based boards - if it's one of those and
>> it runs then I'd be extremely interested!

> I have several Tyan 2882 that use these chipsets running SMP.  I'm
> using LSI MegaRAID cards though, both PCI and PCI-X.  I had issues
> w/the RAID under moderate load that I never got solved but the
> machines run do run SMP.

We have about three dozen 2U and tower servers using Tyan S2882
motherboards, only one of which has the onboard SCSI controller.  They
all use 3Ware Escalade 9550SX RAID controllers (4-port SATA).  They
all run beautifully with FreeBSD 6.1 in 32-bit and 64-bit modes, with
full SMP and ACPI support.  The AMD 8000-series chipset is the most
stable one we've used for amd64 support, in both FreeBSD and Debian

We also ran into an issue with LSI MegaRAID controllers with this
board, though.

Are you running the LSI cards off a riser card, or plugged directly
into the motherboard?  We had tonnes of problems with the LSI MegaRAID
6-port SATA controller when plugged into a riser card (under FreeBSD
6.0/61 32- and 64-bit, and Debian Linux 3.1 32- and 64-bit).  The card
would lose the RAID configuration under load requiring a reboot into
the controller BIOS to fix.  It would attach/detach drives under load,
causing write speed to drop into the single digits.  And data would be
corrupted after heavy use.  It got bad enough that we replaced almost
all of them with 3Ware controllers.

Plugging the MegaRAID controller into a PCI-X slot on the motherboard
of our tower systems solved all of the problems, but was not an option
in our 2U rackmount systems.

For the one system with the onboard SCSI controller, we have it
disabled in the BIOS and use a 12-port 3Ware Escalade 9550SX RAID
controller plugged into a backplane with 12 400 GB drives attached. 
Only tested it for a few days with 64-bit FreeBSD 6.1.  Didn't run
into any problems with it, all devices were detected and every ran
smoothly.  Unfortunately, had to wipe it and install Debian Linux
testing to put it into production.

Freddie Cash
fcash at

More information about the freebsd-amd64 mailing list