Runaway memory usage on 6.1/amd64

Robert Leftwich freebsd at
Tue Jun 13 21:37:58 UTC 2006

I just upgraded a 6.1b4 box that has been very stable and reliable to the 6.1 
release and now have a problem where some of the apps rapidly use a lot more 
memory (>2GB, but on 6.1b4 they never used more than 4-500MB) and lock up on 

This is a recurrence of a problem with 6.0 I had back in February that went away 
when I moved to 6.1 beta. Originally I thought it was due to Postgres not being 
compiled with libpq threadsafe (I'm using psycopg2 which specifically states 
that libpq will leak memory if it is not compiled threadsafe), but that is not 
the case.

I've tried a vanilla 6.1 install (straight off the CD, no cvsup) which installs 
Postgres 8.1.3 and Python 2.4.2, as well as cvsup to the latest 6.1 release and 
updating everything to the latest ports (PG8.1.4 and Python 2.4.3) without 
success. I've also tried a number of different releases of pyscopg2 w/o any change.

In desperation I even tried going back to 6.1b4 but that does not appear to be 
available on any FreeBSD ftp sites.

Can anyone offer any suggestions on how to nail down what the problem is, i.e. 
what, if anything, is different in FreeBSD bwn 6.1b4 and 6.1 release that is 
likely to cause this problem? Or, failing that a pointer to a 6.1b4 site to use.



More information about the freebsd-amd64 mailing list