amd64/99475: Mail attachement was modified

Andrew Reilly andrew-freebsd at
Fri Jul 7 04:59:42 UTC 2006

On Fri, Jul 07, 2006 at 10:54:05AM +0800, Albert wrote:
> It toke me two weeks to find out where the problem is.
> FreeBSD 6.1/amd64 SMP +sendmail 8.13.6 & 8.13.7 and
> FreeBSD 5.4/amd64 SMP +sendmail 8.13.6 & 8.13.7 are both the same result.
> All looks okey. BUT .......
> I use FreeBSD as mail server from 2.2.8 to 5.2.1, it is the first time I 
> met this kind of thing.
> May be it is the bug of sendmail, but it runs no problem on i386 platform.
> Is there huge difference on i386 and amd64 on the topic of mail server?
> My box is a running system, may be I have few chance to try again. Sorry 
> about that!

One other possibility, given that you don't have the problem on
the same box runninng i386 code, could be related to the GCC
compiler bug that I reported in relation to
ports/sysutils/ucspi-tcp recently.  The system default CFLAGS
is -O2 -fno-strict-aliasing, which seems to allow a bug in the
system gcc version 3.4.  Changing -O2 to -O in CFLAGS, or
changing CC from cc to gcc41 (installed from ports) both solved
that problem.  Maybe it will help sendmail too?

(I don't build or run sendmail myself, so I'm not going to test
this theory...)



More information about the freebsd-amd64 mailing list