dual vs single core opteron 100's

Jeff Anton antonfb at hesiod.org
Wed Jan 25 09:06:49 PST 2006

I just finished building an Opteron 165 on a Tyan K8E S2865AG2NRF.
I'm confident that dual core was the right move for me.
Now I have a couple of my own database and computational applications
and I've added threading support to most of these applications.
Matrix multiplication threads like a dream.  Even database stuff
which is just reading records and aggregating improved 25% realtime
at a cost of 165% cpu time relative to 70% cpu time single threaded.
(a lot more thread processing overhead with the db stuff to get
computation done while another thread waits for disk I/O.)

Just operationally, X seems more interactive, but moving windows seems
sluggish I think because the mouse processing produces more intermediate
move points giving a smooth but sluggish window move.

Mozilla is using threads.  W/FreeBSD 6.0 run 'top' then hit 'H' to
see each thread.  My Mozilla currently has five threads.

I have not yet tried overclocking.  I think the Opteron will be fine.
When building the machine I ran for 15 minutes without the cpu fan
due to bumping the fan cable.  (A little concerned that the system
ran at all)  After 15 minutes of fanless operation the BIOS reported
the CPU was 122 deg C.  Hard to believe, but I burned my hand reattaching
the fan power.

For the record the issues I had with putting the system together were:

1. The 2865 MB came with a BIOS v 1.0 which does not recognize dual-core
   (reported unknown processor)  flashed to v 3.01

2. Hard drives were delivered late so I did a test FreeBSD install with
   and old small (20Gbyte) disk.  FreeBSD 6.0 seemed to install but then
   crashed with a divide by zero error.  This is a reported problem
   with the ataraid driver I learned by searching this lists archives.
   However, I also tried moving a disk from a working FreeBSD 6.0/i386
   installation and that also crashed with a divide by zero error
   at the same place.  That this happened with both the amd64 kernel
   and the i386 kernel makes me think this is strictly a motherboard
   (nVidia 4) ataraid driver issue not a strictly amd64 issue.  Maybe
   the bug report should be re-classified.
   I tried a disk with a working FreeBSD 5.4/i386 installation and
   that actually ran but did not find the onboard ethernet.

3. The INSTALL notes still have several references to using floppy
   disks even though there are no floppy disk images.

4. When my SATA disks came I tried the 3.0 Gb mode since the Tyan
   documentation claims the board supports that, but FreeBSD 6.0
   reported SATA150 and crashed being unable to write to the disks.
   Changed disks to 1.5 Gb mode and they worked.  (Actually I had
   one crash due to 'lost mount' which was a cable problem I think.)

5. The reported problem with X11 not working because of no 'sync on green'
   support is a minor problem at best.  Lack of 'sync on green' is
   only an issue with component cableing not an SVGA cable.
   Mind you the onboard ATI Rage XL has only 8 Mbytes of SGRAM
   (Tyan documentation here is poor) so you can not run with
   much resolution using the onboard graphics.

Jeff Anton

More information about the freebsd-amd64 mailing list