amd64/91405: Kernel panic caused by asr on 6.0-amd64 box

Don Brearley donbrearley at
Fri Jan 6 09:20:04 PST 2006

>Number:         91405
>Category:       amd64
>Synopsis:       Kernel panic caused by asr on  6.0-amd64 box
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    freebsd-amd64
>State:          open
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Fri Jan 06 17:20:02 GMT 2006
>Originator:     Don Brearley
>Release:        6.0-STABLE #4
Hibbing Community College
FreeBSD 6.0-STABLE FreeBSD 6.0-STABLE #4: Thu Jan 5 16:01:00 CST
2006    root at amd64
I have a Tyan Thunder S2895 (K8WE) motherboard in which I am trying to use
an Adaptec 2400A ATA-RAID Card (AAR-2400A).  I have dual Opteron 246 CPU's
with 2GB of RAM.  I am using a USB keyboard.

The problem is that I cannot boot the box with the Adaptec Card installed
with ACPI-enabled.  

When I have ACPI enabled, the card is detected and then the kernel panic's
with:  kernel trap 12: page fault in kernel mode, and then reboots.

When I have ACPI disabled, the box boots up just fine but the Adaptec card
is not detected.  

I am enabling/disabling ACPI through hint.acpi.0.disable in /boot/loader.conf
and/or choosing option #1 or #2 in the boot menu.

When I boot the box without the card, in ACPI mode, everything works fine. 

The problem persists in either SMP or non-SMP environments.

The problem persists with multiple Adaptec 2400A cards.  I've tried two others
and both get errors.   I've tried using different PCI slots, and that also
did not correct the problem. 


Get a Tyan S2895 board and an Adaptec ATA-RAID 2400 card.  Install 6.0-release
and try to boot with ACPI-enabled.


None.  You can boot the machine by disabling ACPI, but you will not be able
to use the Adaptec card, so you may as well just remove the card and use ACPI.

Please feel free to contact me for further details.

More information about the freebsd-amd64 mailing list