i386_set_ldt and wine on AMD64

Mike Meyer mwm at mired.org
Sat Dec 30 19:02:11 PST 2006

In <3AE0FE6A-EA8A-44A0-98A5-E2D7E28BC38A at uchicago.edu>, Nathan Whitehorn <nathanw at uchicago.edu> typed:
> One thing you can do (I had to do this for ghostscript, which is  
> broken on amd64)

No, it isn't:

bhuda% file /usr/opt/bin/gs
/usr/opt/bin/gs: ELF 64-bit LSB executable, AMD x86-64, version 1 (FreeBSD), for FreeBSD 6.1 (601104), dynamically linked (uses shared libs), for FreeBSD 6.1 (601104), stripped
bhuda% pkg_info -W /usr/opt/bin/gs
/usr/opt/bin/gs was installed by package ghostscript-gnu-7.07_15

I'm mostly using it as a printer driver, but ghostview hasn't given me
any problems either.

Maybe one of the dependencies that my options didn't pick up that
yours did is broken. Or maybe you tried one of other ghostscript ports
instead. Or maybe you tried it when the port was broken (that got me
with openoffice - the tarball the port grabbed by default was
corrupt). But ghostscript has always built on amd64 with no problems
for me.

Mike Meyer <mwm at mired.org>		http://www.mired.org/consulting.html
Independent Network/Unix/Perforce consultant, email for more information.

More information about the freebsd-amd64 mailing list