BTX halted trying to boot X4100 from disk

Torfinn Ingolfsen torfinn.ingolfsen at
Thu Dec 7 13:24:12 PST 2006

On Thu, 07 Dec 2006 17:28:19 +1100
Peter Jeremy <peterjeremy at> wrote:

> At what point during the boot process does it die?  If it's late

Detailed description:
1) I turn on the laptop
2) I press  "F12" (bios multibooot)
3) I select the usb HDD from the bios boot menu
4) the FreeBSD boot selector comes up, allowing me to choose F1, F2 or
    F5. F1 and F2 are FreeBSD partitions on which I have installed
    FreeBSD up to the reboot point. F5 is "drive 1".
5) I press "F1" (or "F2" doesn't make a difference) and the register
    dumps or whatever it is starts scrolling across the screen. At this
    point, the laptop doesn't react to any key press at all, the only
    thing that works is to use the power off button.
    (Normally, if the keyboard was alive I would have been able to fill
    the keyboard buffer until I got beeps)

Another data point: if I press "F5" (drive 1), the laptop just prints
"missing operating system", and then I can reboot it with Ctrl-Alt-Del.

More info: the laptop doesn't have any problems booting from the
internal drive, I have tried both FreeBSD 6 and 7 with the FreeBSD
boot selector / loader. Currently it has WinXP, FreeBSD 6 and Xubuntu on
the internal drive, using the NT / XP boot loader.

Also, the laptop boots FreeBSD install CD's (i386) easily, this is how
I have managed to install FreeBSD on those two partitions on the usb
hard drive.

Also, on another usb hard drive, i have installed NetBSD and OpenBSD,
using the NetBSD boot loader. Both NetBSD and OpenBSd boots fine

Final note: the laptop have a Intel Core Duo cpu, which means that I
have only tried FreeBSD / i386  on it.

Torfinn Ingolfsen

More information about the freebsd-amd64 mailing list