amd64 Radeon 9000 nForce3 250 agp support - Yes and No

K. Wieland wieland.k at
Thu Sep 15 07:23:17 PDT 2005

Jung-uk and fellow amd64 subscribers,

I tried upgrading to 6.0B4 last night, after spending several nights  
reading the documentation.  I have been reading and am subscribed to  
the amd64 list, so I figure I might as well try it!

First, I mounted the new 6.0_B4 CD under 5.4 and tried to run the  
sysinstall that way as outlined in the docs (I don't remember where,  
but I can get the reference).  sysinstall (v6.0 B4) would not run,  
complaining about some libraries not being present (I had a previous  
version of the libraries it was looking for, so I made sym links (bad,  
I know!) but it failed looking for the next library, so I deleted the  
symlink, and decided to reboot with the CD.

I rebooted, went into fixit and did a dmesg.  AGP was there, and the  
device /dev/agpart existed.  I was happy, and decided to upgrade to 6.0  
beta4 using the upgrade option in sysinstall.  I didn't remember the  
mount points for the various file systems so I had to boot back into  
5.4 and write it all down (it would be nice if this was in the  

Anyway,  I upgraded and rebooted.  The first thing I noticed was the  
generic kernel detected my com port, but didn't create a /dev/cuaa0 (I  
dial up for internet).  And, because I want sound and my TV card (bktr)  
I decided to customize the kernel like I had done in 5.4.

So, I did a diff of the GENERIC to the custom kernel, MYKERNEL, and  
found that it was basically the same (MYKERNEL had the sound, bktr, and  
agp with several extraneous things commented out).  I built the new  
kernel, installed it and rebooted.  AGP was gone!  I thought, well  
maybe you don't need "device agp" in the kernel (I didn't see it in the  
GENERIC, and agp loaded with that), so I tried that...still no AGP.   
Then, I decided to use the GENERIC and see if that worked---still no  
AGP.  But, if I boot up with the CD, AGP is back!

The confusing part to me is that the uname -a still gives me RELENG5.4  
-p7.  That seems strange to me.  The ps command also didn't work as  
expected (just prints the headers, none of the processes).

I read that if your sources don't match your kernel, you can get weird  
stuff like this, so I went to cvsup to the most recent.  BUT, in the  
/usr/share/examples/standard-cvsup files it still had RELENG 5.4.  I  
went ahead and cvsup'ed anyway.

I don't have anything critical on the drive, so I am tempted to wipe it  
clean and reinstall (ala windows style) but I would really like to  
understand what is going on here.

I am CCing the freebsd-amd64 list in case they have some insights, too.


Kristopher Wieland
Graduate Student
Washington University in St. Louis
Dept. of Physics- Compton Hall
On Sep 13, 2005, at 11:40 AM, Jung-uk Kim wrote:

> On Tuesday 13 September 2005 12:19 pm, K Wieland wrote:
>> Thanks again for the quick reply.
> No problem.
>> Is there a "best method" for installing another version?  I would
>> rather not loose the kernel config, etc.  Is it best to just wipe
>> everything and start over?
> cvsup, buildworld, installworld, mergemaster...  But it's quite a
> hassle for new users.  First of all, if the only problem for you is
> the agp, try booting from the ISO, select Fixit, select CD/DVD, then
> you will get shell.  You can see if agp is probed/attached from
> there.  If that's there, you have two choices:
> 1.  Upgrade.
> 2.  Patch kernel to add support for the AGP device.
> If you choose option 2, the only thing you really need is this:
> r1=1.6&r2=1.7
> Good luck,
> JK
>> I'll give it a try and see how it goes!
>> Kristopher
>> On Sep 13, 2005, at 10:17 AM, Jung-uk Kim wrote:
>>> On Tuesday 13 September 2005 11:06 am, K. Wieland wrote:
>>>> Thank you for your quick reply!
>>>> Yes, I am using 5.4 Release.  I guess since I was just starting
>>>> out with Freebsd, I'd go with "release" vs. stable or current.
>>>> Do you know an ftp site for getting the images for 6.0 beta4?
>>>> Or should I just cvsup to it?  You can tell I am new, new new!
>>> JK
>>>> Thanks,
>>>> Kristopher
>>>> On Sep 13, 2005, at 9:54 AM, Jung-uk Kim wrote:
>>>>> On Tuesday 13 September 2005 10:42 am, K. Wieland wrote:
>>>>>> Hello Jung-uk!
>>>>>> I was reading through the archives of the freebsd-amd64
>>>>>> archives (I am a new Freebsd user) and I have the exact same
>>>>>> problem that you and Geneal talked about.
>>>>>> I also have a radeon 9000 with a nForce3 250 chipset that does
>>>>>> not detect the agp, even though it is in the kernel.
>>>>>> Did you ever get this issue resolved?
>>>>> Are you using FreeBSD 5.4 or something?  Try 6.0BETA4.  It
>>>>> should be fine.
>>>>> JK
>>>>>> Thank you,
>>>>>> Kristopher Wieland

More information about the freebsd-amd64 mailing list