can't see onboard NIC

Jeff D. Hamann jeff.hamann at
Thu Sep 8 09:57:38 PDT 2005


I've been trying to get FreeBSD-6BETA up and running (after having some 
troubles trying to get 5.4 running) on a new AMD64 system. The system is an 
ASUS vintage-ae1 with an onboard NIC (I'm not what kind other info I can 
provide since the web link for the mb specs is down on the asus website)...

When I run dmesg, I get the following lines (I can't post the whole thing 
since I can't get files from the bsd box to my windows box -- no mcopy and I 
don't knwo how to mount the usb stick either):

plip0: <PLIP network interface> on ppbus0

and when I type ifonfig, I get:

mtu 1500
lo0: flags=blah,blah,blah....

and that's it. So my questions are:

1) how do I get the nic up? kernel recompile? how and with what settings? It 
seems there are a gazillion ethernet interfaces already in the 
/usr/src/sys/amd64/conf/GENERIC file. Do I need to add the entry for in the 
/boot/device.hints file? Is there a way to do this without a kernel 
recompile using some settings in the /boot/defaults/loader.conf file?

2) how do I get the usb mounted (or even better automounted)?

3) I'm guessing that I need to make changes to the kernel in 
/usr/src/sys/amd64 and not /usr/src/sys/i386, Yes?

Also, I've tried to simply insert a usb stick into the front port and when I 
removed the device, the machine rebooted.

Is there any more information I can provide to help solve this?


Jeff D. Hamann
Forest Informatics, Inc.
PO Box 1421
Corvallis, Oregon USA 97339-1421
jeff.hamann at

More information about the freebsd-amd64 mailing list