FreeBSD 5.4 on a Sun Fire v40z

Matteo Quintiliani quintiliani at
Thu Oct 20 07:07:04 PDT 2005

On 20 Oct 2005, at 13:46, Matteo Quintiliani wrote:
> Hi,
> yesterday I tried to install FreeBSD 5.4-amd64 on a Sun Fire v40z.
> Installation works fine, it finds any hardware and I'm able to  
> configure any setting.
> The problem occurs when server is booting. I get a black screen and  
> the server reboot automatically.
> Server has 4 processors AMD Opteron 850 and 2 scsi hard disk 73GB.
> I tried to:
> - use only a disk, the problem is the same
> - install both "Standard boot" and "FreeBSD Boot Manager", the  
> problem is the same.
> I noticed in FDisk that, after the installation, the freebsd slice  
> lost "bootable" property.
> Please, could someone help me?

I've solved the problem booting FreeBSD from the CDROM
and launching  the following line commands: [FreeBSD Handbook pages  

fdisk -B -b /boot/boot0 da0
disklabel -B da0s1

I don't know yet when I made mistakes during the installation.

Matteo Quintiliani

More information about the freebsd-amd64 mailing list