More about the 9500S-4 issues with the MoBo and FreeBSD...

Olaf Greve o.greve at
Tue Nov 29 09:45:57 GMT 2005

Hi again,

Well, the plot thickens... Yesterday the machine was brought to my place 
  (unfortunately without the user manuals :( ), so I could give various 
things a try.

Bottomline: still no solution.

I'll do my best to abbreviate the report of the many things I tried. 
Summed up, they come down to the following (note: I'm very heavily 
suspecting a conflict with the MoBo and/or chipset, and/or memory):

* The MoBo is an Asus A8N-SLI premium. I just discovered that more 
people have had issues with this combination. E.g. check: (found 
using Google, with the terms "asus a8n-sli premium 3ware 9500 problem" - 
I have yet to check if one of the links perhaps mentions a solution).

* The chipset is an nforce one; I think it was 4, but perhaps it's 3.

* The controller is the 9500S-4LP controller.

* I did not flash the 9500S-4LP controller's Firmware. Maybe that would 
yield a solution, but what I gather from the above URL it may not). I'll 
have a look-see to see what the latest firmware version is...

* Other than the controller and the video board, there were no other 
boards used (i.e. I took both NICs out straight away).

* I called the US ACMM support line, and the controller cannot be 
jumpered or otherwise configured to enforce a specific IRQ. Instead, 
putting it in different PCI slots should take care of that.

* I tried pretty much all combinations of the board in the various PCI 
slots (all 32-bits), both in combination with the AGP video board, as 
well as in combination with a PCI video board. No solution there.

* I tried disabling virtually everything in the BIOS but for 1 IDE 
channel (which I need for the FreeBSD CD-ROM) and the CPU. :D
No solution there.

* I tried overriding the Auto PCI IRQ settings, but unfortunately it 
only allows individual lines to be switched between "Auto" and 
"Reserved". I tried flagging the seemingly conflicting lines as 
reserved, but the machine then just reassigned different IRQ lines to 
the same possibly conflicting devices.

* The only thing which caused FreeBSD to not hick-up, was to completely 
remove the 3ware controller, and just plug in one drive on one of the 
on-board normal SATA controllers (I guess this will work with the other 
SATA controllers and multiple drives, as well as the on-board RAID 
controller as well). That way no errors were given by FreeBSD, and it 
would actually try to install (needlessly to say, I aborted the actual 

* The returned errors from FreeBSD come in two varieties; one very quick 
hang (with the "unposted command completed!! error", and one in which 
FreeBSD returns many more errors (including stuff like a firmware vs. 
driver mismatch, which may be of importance), but in which FreeBSD most 
of the times manages to pull through until sysinstall (and then simply 
mentions there are no HDs). The difference between these two is 
reproducable by disabling/enabling lots of on-board stuff (dunno from 
the top of my head which one is the culprit).

* One of the errors FreeBSD gives for the 9500S mentions "...irq 18 at 
device 8.0 on pci5". Interestingly enough, a further error (or warning, 
or just "info") is given that something from Texas Instruments (the 
memory, I guess ?!?) is also located on pci5 (I couldn't write down the 
exact error)... Perhaps a suspect?

Good, so far for a 'bulleted' report. In order to give more complete 
information I have listed some more debug information down below. Maybe 
someone can spot something off in it?

Firstly, a typical list of PCI devices at boot time (with already lots 
of stuff such as the audio controller, etc. disabled):

PCI device listing:
Bus No.  Device No.  Func. No.  vendor/device  class  device class  IRQ
    0         1           1       10DE  0052    0C05   SMBus contr.   4
    0         7           0       10DE  0054    0101   IDE contr.     11
    0         8           0       10DE  0055    0101   IDE contr.     5
    1         0           0       10DE  0161    0300   Display contr. 12
    5         8           0       13C1  1002    0104   RAID contr.    12
    5         11          0       104C  8023    0C00   Serial bus     3
                                                       ACPI contr.    9

Perhaps the display controller bites the RAID controller (at least: both 
use the same IRQ)?

In an even more minimal set-up, and using the PCI video board instead of 
the AGP one, a typical listing looks like:

PCI device listing:
Bus No.  Device No.  Func. No.  vendor/device  class  device class  IRQ
    0         1           1       10DE  0052    0C05   SMBus contr.   7
    6         0           0       102B  0525    0300   Display contr. 10
    5         8           0       13C1  1002    0104   RAID contr.    11
    5         11          0       104C  8023    0C00   Serial bus     3
                                                       ACPI contr.    9

So, seemingly no more shared IRQs, yet the trouble remained. :(((

The 9500S BIOS reports the following upon booting:
Escalade 9500S-4LP
Firmware: FE9X

The short FreeBSD error/info is:
3ware device driver for 9000 series storage controllers, version
twa0: <3ware 9000 series storage controller> port 0xa000-0xa0ff mem 
0xd8005000-0xd80050ff, 0xd2000000-0xd27fffff irq 18 at device 8.0 on pci5
twa0: Error: (0x15: 0x1201): Unposted command completed!!: 
Request=0xffffffff810452ee, status=0
twa0: INFO: (0x16: 0x1108): Resetting controller...:

At that point FreeBSD hangs.

The other version of errors show many more errors (which flash by too 
quickly in order to be written down, and the "pause" key doesn't pause 
the screen). They include things like:
-Can't drain the AEN queue
-Driver/Firmware mismatch
-Unposted command completed!!

And several other things...

I hope someone has any idea or a solution, as it's not really an option 
to use the on-board RAID controller for obvious reasons, and we also 
really rather would not want to have to use a different MoBo...:((

Thanks again, and cheers!

More information about the freebsd-amd64 mailing list