problems booting recompiled 5.4-kernel (Was: amd64 does not see all 4 GB RAM on tyan GT24)

Claus Guttesen kometen at
Wed Nov 9 02:22:17 PST 2005

> > I have problems booting a recompiled kernel with FreeBSD 5.4 stable. I
> > thought it was related to enabling smp in the kernel, but I have just
> > rebuild kernel without smp (and rebuild world as well) and the server
> > did not come back up.
> >
> > When I rebooted a recompiled kernel it stopped with calcru negative
> > time so I tried to change kern.timecounter.hardware to i8254 in
> > /boot/loader.conf, but it seems to ignore my hint. Doing a sysctl
> > kern.timecounter.hardware (when booting the original kernel from the
> > installation) shows ACPI-fast.
> >
> > I added CPUTYPE=k8 to /etc/make.conf.
> >
> Undo the changes you made to the kernel (or go back to GENERIC) and
> other configuration and verify that it works again.  If so, that means
> you may have made a mistake in those changes.

Thank you for your reply, I (allready) did that when I came back to
work. The new kernel works now, the line that I commented out and
caused the trouble was:

# Workarounds for some known-to-be-broken chipsets (nVidia nForce3-Pro150)
device          atpic           # 8259A compatability

Now it's activated again and the server can boot without problems. The
reason I commented out the line is because the board is has a

I tried FreeBSD 6.0 a few days ago and I seem to recall that the above
mentioned line is not needed in FreeBSD 6.0, but my (own) memory is
probably corrupt :-)


More information about the freebsd-amd64 mailing list