busdma dflt_lock on amd64 > 4 GB

Jan Mikkelsen janm at transactionware.com
Tue Nov 8 05:28:19 PST 2005


Attila Nagy wrote:
> It seems that this is the last post in this topic. I have an HP DL145G2 
> with 4 GB RAM (dual AMD64) and with two SATA disks, on which I created a 
> mirror (gmirror).
> It dies with this in the moment I issue gmirror insert ad6 on a degraded 
> mirror.
> Setting hw.physmem below 4G solves the issue.
> The interesting stuff is that the machine worked with 4G with earlier 
> kernels (6.0-BETA5 I think).
> What has changed?

I have seen this too, on the same hardware.  A HP DL145G2 with 4G 
memory;  after touching the SATA disk (immediately after selecting a 
shell going into single user mode, after the date/time display on a 
multiuser boot) the system panics.

This is using PseudoRAID, not gmirror.

It worked with 6.0-BETA1.  I think it broke with BETA5, but it could 
have been shortly after.

Also, after failure, the ar(4) mirror is broken.  "atacontrol rebuild" 
stays on 0% with BETA1.  The rebuild works if I run it after booting 
from a 5.4 CD.


Jan Mikkelsen

More information about the freebsd-amd64 mailing list