Asus A8N-SLI issues

O. Hartmann ohartman at
Sun May 1 08:04:16 PDT 2005

Peter Korsten wrote:
> Hi,
> I've been using FreeBSD on and off since version 2.something, but only 
> recently I got an Asus A8N-SLI (not the Deluxe version) and installed 
> 5.3 on it, from the link you get from the download page.
> There's the ACPI freeze problem, and I've found some references that 
> this will be solved at a later stage. Fair enough.

Can you obtain more specific informations? It is known that nForce4 
based chipsets need the option NO_MIXED_MODE to be commented out in the 
kernel config file! Also you have to define device atpic to make the 
board properly work.

#options	NO_MIXED_MODE
device		atpic
> The thing that I wonder about, though, is why the Ethernet port does not 
> get recognised. This is not the same as in the Deluxe version, where I 
> believe there is a different controller from the nForce4 chipset. Oddly 
> enough, it does recognise the nForce4 Firewire controller and proposes 
> to do TCP/IP over it. Could this be an issue of the 'firewall' hardware 
> that this board comes with?

The Deluxe-version of this mainboard has an additional Marvel NIC 
onboard in addition to the nVidia NIC. I guess the non-Deluxe version 
has only the nForce4-inherent NIC and this NIC is not yet supported by
FBSD 5.4 but 6.0-CURRENT has a driver.

> X isn't doing a lot either, but I've never found it easy to set that up, 
> so I'll look some more into it.

I run A8N-SLI Deluxe with a nVidia based 6600 chipset graphics card 
without problems. There is no acceleration, so expect good 'brute force' 
2D performance, but poor 3D performance (due to lack of suitable drivers 
for amd64/FreeBSD).

> The S-ATA disc is recognised as UDMA33, but at least it knows the 
> correct size of the disc, contrary to some OS from Washington state that 
> I could mention.

This is the same to me and it is due to the lack of a suitable driver. 
The kernel does report the controller as a GENERIC type and 'recognizes' 
the speed as UDMA33, but I do not know whether the hard disk is really 
driven as a UDMA33 device or is in contrary to the kernel report driven 
at full speed.


More information about the freebsd-amd64 mailing list