FBSD 5.3 + amd64 + php + mysqli extension = segfault

Oliver Schonrock oliver.schonrock at realtsp.com
Sun May 1 03:38:33 PDT 2005


We run 4 FreeBSD servers now and have just built first FBSD server on 
AMD64. Everything went quite smoothly using the amd64 version of freebsd.


I tried to use the mysqli extension in php5.0.4 on apache 1.3.33 
connecting to mysql-server-4.1.11 (all built from cvsup'd ports tree).

in php mysql_connect() works ok, but the mysql_fetch_array() segfaults.

this simple php script produces the error every time (via apache or with 
command line binary):


$db = new mysqli('localhost', 'root', 'mysqlrootpw', 'mysql');

$result = $db->query('select * from user;');

while ($row = $result->fetch_array(MYSQLI_ASSOC))


=> Segmentation fault (core dumped)

the php-mysql (note no 'i') extension works fine.

system info:
root at pakiri# uname -a
FreeBSD pakiri.realtsp.com 5.3-RELEASE FreeBSD 5.3-RELEASE #0: Fri Nov 
5 03:50:01 UTC 2004 
root at fanboy.samsco.home:/usr/obj/usr/src/sys/GENERIC  amd64

I have reverted to a generic kernel to avoid any issues there (had 
previously built kernel without unneeded hardware support etc)

We have exactly the same applications running on several i386 (AMD 
Athlon and Intel Pentium) servers. These do not segfault.

I have tried de/reinstalling the mysql, php, mysqli builds in many 
different ways (incl not in combination with mysql extension)...no change.

Does anyone have any experiience running FBSD 5.3 + amd64 + php5.0.4 + 
mysqli extension? Or have any suggestions of how to track this down further?

Thanks in advance


More information about the freebsd-amd64 mailing list