twa breakage on AMD64 with UTC RELENG_5 commit

Michael Meltzer mjm at
Tue Jan 18 20:03:40 PST 2005

straight boot, no patches or extra debug.


Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD 5.3-STABLE #14: Thu Jan 13 23:55:20 EST 2005
    root at
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: AMD Opteron(tm) Processor 240 (1403.19-MHz K8-class CPU)
  Origin = "AuthenticAMD"  Id = 0xf51  Stepping = 1
  AMD Features=0xe0500800<SYSCALL,NX,MMX+,LM,3DNow+,3DNow>
real memory  = 6442450944 (6144 MB)
avail memory = 5963796480 (5687 MB)
ACPI APIC Table: <PTLTD          APIC  >
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
 cpu0 (BSP): APIC ID:  0
 cpu1 (AP): APIC ID:  1
MADT: Forcing active-low polarity and level trigger for SCI
ioapic0 <Version 1.1> irqs 0-23 on motherboard
ioapic1 <Version 1.1> irqs 24-27 on motherboard
ioapic2 <Version 1.1> irqs 28-31 on motherboard
acpi0: <PTLTD    XSDT> on motherboard
acpi0: Power Button (fixed)
acpi0: Sleep Button (fixed)
unknown: I/O range not supported
unknown: I/O range not supported
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x8008-0x800b on acpi0
cpu0: <ACPI CPU> on acpi0
cpu1: <ACPI CPU> on acpi0
acpi_button0: <Power Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib1: <ACPI PCI-PCI bridge> at device 6.0 on pci0
pci1: <ACPI PCI bus> on pcib1
pci1: <display, VGA> at device 6.0 (no driver attached)
isab0: <PCI-ISA bridge> at device 7.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <AMD 8111 UDMA133 controller> port 
0x1020-0x102f,0x376,0x170-0x177,0x3f6,0x1f0-0x1f7 at device 7.1 on pci0
ata0: channel #0 on atapci0
ata1: channel #1 on atapci0
pci0: <serial bus, SMBus> at device 7.2 (no driver attached)
pci0: <bridge, PCI-unknown> at device 7.3 (no driver attached)
pcib2: <ACPI PCI-PCI bridge> at device 10.0 on pci0
pci2: <ACPI PCI bus> on pcib2
bge0: <Broadcom BCM5702 Gigabit Ethernet, ASIC rev. 0x1002> mem 
0xfd000000-0xfd00ffff irq 27 at device 3.0 on pci2
miibus0: <MII bus> on bge0
brgphy0: <BCM5703 10/100/1000baseTX PHY> on miibus0
brgphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseTX, 
1000baseTX-FDX, auto
bge0: Ethernet address: 00:50:45:5b:8e:76
bge1: <Broadcom BCM5702 Gigabit Ethernet, ASIC rev. 0x1002> mem 
0xfd010000-0xfd01ffff irq 27 at device 4.0 on pci2
miibus1: <MII bus> on bge1
brgphy1: <BCM5703 10/100/1000baseTX PHY> on miibus1
brgphy1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseTX, 
1000baseTX-FDX, auto
bge1: Ethernet address: 00:50:45:5b:8e:77
atapci1: <Promise PDC20319 SATA150 controller> port 
0x3000-0x307f,0x30c0-0x30cf,0x3080-0x30bf mem 
0xfd020000-0xfd03ffff,0xfd040000-0xfd040fff irq 25 at device 5.0 on pci2
atapci1: failed: rid 0x20 is memory, requested 4
ata2: channel #0 on atapci1
ata3: channel #1 on atapci1
ata4: channel #2 on atapci1
ata5: channel #3 on atapci1
pci0: <base peripheral, interrupt controller> at device 10.1 (no driver 
pcib3: <ACPI PCI-PCI bridge> at device 11.0 on pci0
pci3: <ACPI PCI bus> on pcib3
3ware device driver for 9000 series storage controllers, version:
twa0: <3ware 9000 series Storage Controller> port 0x4000-0x40ff mem 
0xfd800000-0xfdffffff,0xfd100000-0xfd1000ff irq 30 at device 2.0 on pci3
twa0: 4 ports, Firmware FE9X, BIOS BE9X
pci0: <base peripheral, interrupt controller> at device 11.1 (no driver 
atkbdc0: <Keyboard controller (i8042)> port 0x64,0x60 irq 1 on acpi0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model IntelliMouse, device ID 3
fdc0: <floppy drive controller> port 0x3f7,0x3f0-0x3f5 irq 6 drq 2 on acpi0
fdc0: [FAST]
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on 
sio0: type 16550A, console
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
ppc0: <ECP parallel printer port> port 0x778-0x77f,0x378-0x37f irq 7 drq 
4 on acpi0
ppc0: Generic chipset (ECP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/8 bytes threshold
ppbus0: <Parallel port bus> on ppc0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
orm0: <ISA Option ROMs> at iomem 
0xcb000-0xcc7ff,0xc9800-0xcafff,0xc8000-0xc97ff,0xc0000-0xc7fff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x100>
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounters tick every 1.000 msec
IP Filter: v3.4.35 initialized.  Default = pass all, Logging = disabled
acd0: DVDROM <IDE DVD-ROM 16X/VER 2.50> at ata0-master UDMA33
SMP: AP CPU #1 Launched!
Mounting root from ufs:/dev/da0s1a
setrootbyname failed
ffs_mountroot: can't find rootvp
Root mount failed: 6

Manual root filesystem specification:
  <fstype>:<device>  Mount <device> using filesystem <fstype>
                       eg. ufs:/dev/da0a
  ?                  List valid disk boot devices
  <empty line>       Abort manual input

Vinod Kashyap wrote:

>I tried reproducing the problem on both i386 and amd64,
>but could not.  I installed 5.3 RELEASE, cvsuped to the
>tip of RELENG_5, re-built the kernel with twa integrated,
>and rebooted.  The test systems booted just fine (off of
>3ware controlled da0).  I even tried replacing just the
>twa sources of 5.3 RELEASE with the twa sources from the
>tip of RELENG_5, and that worked fine too.  All this,
>without even upgrading the firmware from (which
>is bundled into 5.3 RELEASE sources).  So, I am confused as
>to what might be happening.
>Could you give the attached patch a try?  Just a hunch...
>>-----Original Message-----
>>From: owner-freebsd-stable at
>>[mailto:owner-freebsd-stable at]On Behalf Of Michael Meltzer
>>Sent: Friday, January 14, 2005 6:03 AM
>>To: Vinod Kashyap
>>Cc: freebsd stable
>>Subject: Re: twa breakage on AMD64 with
>>3wareversionand2005-01-1103:00:49 UTC RELENG_5 commit
>>>Could you see if the driver is getting loaded?  The driver prints
>>>the message: "3ware device driver for 9000 series storage 
>>>Did the new firmware get flashed?  You can download the firmware
>>>from the 3ware website and flash it on the card using a DOS floppy.
>>>Alternatively, you can add 'options TWA_FLASH_FIRMWARE' to your
>>>kernel configuration file and rebuild the kernel.  This should build
>>>the kernel/driver with the firmware bundled, and the firmware should
>>>automatically get downloaded the next time you reboot.
>>I reloaded the new driver and rebuilt the kernel last night with the 
>>TWA_FLASH_FIRMWARE, Did not see the -D on the command line for the 
>>rebuild, the new firmware was not requested to load. I got the new 
>>firmware from 3ware and flashed it in, Still does not work. I 
>>also build 
>>a straight GENERIC Kernel, still no luck. Their is no error 
>>message that 
>>I saw and the versions number for the pieces did change so it 
>>the "new" 
>>stuff. I need to setup a serial console to capture the full messages, 
>>should have that on monday night. Thank You -mjm
>>freebsd-stable at mailing list
>>To unsubscribe, send any mail to 
>>"freebsd-stable-unsubscribe at"

More information about the freebsd-amd64 mailing list