hardware monitoring support for MSI RS480M2-IL (aka MS-7093) motherboard?

Torfinn Ingolfsen torfinn.ingolfsen at broadpark.no
Sun Dec 25 06:53:13 PST 2005


Does anyone have success in getting a hw monitoring program (you know,
cpu temp, fan speeds, etc) working with the MSI RS480M2-IL (aka MS-7093)

I'm running FreeBSD 6.0-stable / amd64 o this motherboard. There
shouldn't be any difference from running the i386 version, with regards
to hardware monitoring?

I have tried xmbmon from ports, but it just says:
root at kg-quiet# mbmon -d -A
Summary of Detection:
 * No monitors found.
InitMBInfo: Unknown error: 0
This program needs "setuid root"!!

I really don't know why it prints that last line, the program is setuid
root already:
root at kg-quiet# ls -l `which mbmon`
-r-sr-xr-x  1 root  wheel  52064 Dec 25 13:34 /usr/local/bin/mbmon

A 'mbmon -D' gives:
root at kg-quiet# mbmon -D
Probe Request: none
>>> Testing Reg's at ISA-IO <<<
[ISA Port IO-Base:0x290]
Probing Winbond/Asus/LM78/79 chip:
  CR40:0xFF,  CR41:0xFF,  CR42:0xFF,  CR43:0xFF
  CR44:0xFF,  CR45:0xFF,  CR46:0xFF,  CR47:0xFF
  CR48:0xFF,  CR49:0xFF,  CR4A:0xFF,  CR4B:0xFF
  CR4C:0xFF,  CR4D:0xFF,  CR4E:0xFF,  CR4F:0xFF
  CR56:0xFF,  CR58:0xFF,  CR59:0xFF,  CR5D:0xFF
  CR3E:0xFF,  CR13:0xFF,  CR17:0xFF,  CRA1:0xFF
  CR20:0xFF,  CR22:0xFF,  CR23:0xFF,  CR24:0xFF
  CR27:0xFF,  CR29:0xFF,  CR2A:0xFF,  CR2B:0xFF
No Hardware Monitor found!!
InitMBInfo: Unknown error: 0

Does anybody know what hw monitoring chip this motherboard have? 
And where that chip is connected? Is it connected to the SMbus
controller in the SB400 southbridge?

I tried Google, buth couldn't find any good info.
Torfinn Ingolfsen,

More information about the freebsd-amd64 mailing list