Slow PCI-X controller perfomance (adaptec 2130SLP)

Vasim Valejev vasim at
Fri Aug 19 09:27:55 GMT 2005

Hi !

I've tried to set up FreeBSD-current on Dual opteron box with Adaptec 2130SLP
PCI-X RAID controller (256MB memory). My tests did show that maximum transfer
rate from controller to OS was about 132MB/s. That is very strange since PCI-X
maximum speed should be about 1GB/s. Why the controller was so slow? Because
poor driver or my method of the test?

To test transfer rate, i just did run command "dd if=/dev/aacd1 of=/dev/null
bs=8k count=4k" many times (may be i'm wrong but the controller shall cache this
request in its memory). Change of hw.aac.iosize_max to 98k did a very little

My system config:

Tyan K8SD Pro (S2882-D) motherboard (onboard SATA controller was turned off)
2xOpteron 244
2GB memory (2x512MB RAM stick for each CPU)
Adaptec 2130SLP RAID controller with 256MB memory and backup battery (tried
every PCI-X slot on the MB with same results)
Six Maxtor Atlas 15K2 36GB drives (8E036J0) on the SCSI channel (but only four
was used for /dev/aacd1, RAID5 with 64K stripe)

FreeBSD7.0-CURRENT/amd64 (Tested with 5.4-RELEASE/amd64 and 6.0-BETA2/386 but no

Vasim V.

More information about the freebsd-amd64 mailing list