kern/84930: something wrong with msdosfs on amd64

Giorgos Keramidas keramida at
Tue Aug 16 10:00:38 GMT 2005

The following reply was made to PR amd64/84930; it has been noted by GNATS.

From: Giorgos Keramidas <keramida at>
To: "Mikhail T." <mi at>
Cc: bug-followup at
Subject: Re: kern/84930: something wrong with msdosfs on amd64
Date: Tue, 16 Aug 2005 02:43:15 +0300

 On 2005-08-14 15:14, "Mikhail T." <mi at> wrote:
 > I just tried to move some songs over to the IRiver MP3-player.
 > USB code recognized the device:
 > 	da1 at umass-sim0 bus 0 target 0 lun 0
 > 	da1: <TOSHIBA MK4004GAH JC00> Fixed Direct Access SCSI-0 device
 > 	da1: 1.000MB/s transfers
 > 	da1: 38147MB (78126048 512 byte sectors: 255H 63S/T 4863C)
 > and I was able to mount it:
 > % mount -t msdosfs /dev/da1s1 /iriver
 > The drive on it is just over half-full and df confirms it:
 > /dev/da1s1         39052512 19902080 19150432    51%	/iriver
 > Yet, when I tried to list the contents of the drive, I saw nothing:
 > 	% ls -l /iriver
 > 	total 0
 > Another system -- i386 running 5.4-stable from April 23 -- had no
 > problems and is busy copying the files as I type this.
 > >How-To-Repeat:
 > Try to write to an msdosfs on amd64.
 This may be unrelated, but I'm successfully using a JetFlash USB stick
 to move small amounts of data between my i386 7.0-CURRENT workstation
 and my amd64 laptop.  So far things seem to work fine, so it may be a
 bug that is not related to msdosfs.
 Another thought is that I had similar problems with msdosfs and cd9660
 filesystems when I tried to read their contents from a root shell (which
 doesn't have any LC_XXX or LANG environment vars), especially when the
 filesystem contained Greek filenames.  Setting up the correct locale
 fixed everything.
 I'm not saying that nothing is wrong with msdosfs on amd64.  Just adding
 what I've seen so far, in case it helps track down the cause of your

More information about the freebsd-amd64 mailing list