Juergen Lock nox at jelal.kn-bremen.de
Thu Aug 11 19:44:32 GMT 2005

After further installing my new amd64 box (yes, if_sk works now :)
I just tried a few guests with qemu-system-x86_64:

amd64 guests, no kqemu:

 KANOTIX-64-2005-03.iso (kernel 2.6.11 iirc, booted in text mode
without `quiet') hangs after printing `Brought up 1 CPUs'

 5.4-RELEASE-amd64-disc1.iso (FreeBSD) works (tested fixit -> cdrom
which gives a shell)

i386 guests, no kqemu (all work in i386-softmmu qemu):

 KANOTIX-2005-03.iso (kernel 2.6.11, booted in text mode without `quiet'):
hangs after printing `Checking if this processor honours the WP bit even
in supervisor mode... Ok.'  (on i386-softmmu the next message is
`Calibrating delay loop... ...')

 KNOPPIX_V3.8-2005-02-28-CeBIT_Edition.iso (kernel 2.6.11 SMP, booted in
text mode) hangs too after printing `ACPI: Unable to locate RSDP'
(has `quiet' in the boot config), same thing with `acpi=off' apart from
the missing ACPI message

 KNOPPIX_V3.7-2004-12-08-DE.iso works with kernel 2.4.27 SMP, hangs with
kernel 2.6.9 (type `knoppix26' at the boot prompt), also after printing
`Checking if this processor honours the WP bit even in supervisor mode... Ok.'

 5.4-RELEASE-i386-disc1.iso panics after printing `avail memory ...'
with a page fault, supervisor read, page not present at 0x1c,
ip 0x8:0xc0762fbc which is vm_fault+440: the insn is cmpxchg %ecx,0x1c(%edx)
which seems to be part of VM_OBJECT_LOCK(fs.first_object);
so apparently fs.first_object is NULL. (line 291 of
RELENG_5_4_0_RELEASE sys/vm/vm_fault.c, available at
revision, the disassebly can be viewed in fixit in i386-softmmu
with kgdb /dist/boot/kernel/kernel /dev/mem, then: disas vm_fault)

with kqemu:

 KNOPPIX_V3.7-2004-12-08-DE.iso crashes with:
EAX=00000000 EBX=00000000 ECX=00000000 EDX=00000000
ESI=00000000 EDI=00000000 EBP=00000000 ESP=bffffeb0
EIP=08048074 EFL=00000203 [------C]    CPL=3 II=0 A20=1
ES =0023 00000000 ffffffff 00cff300
CS =0023 00000000 ffffffff 00cffa00
SS =002b 00000000 ffffffff 00cff300
DS =0023 00000000 ffffffff 00cff300
FS =0023 00000000 00000000 00000000
GS =0023 00000000 00000000 00000000
LDT=0068 c02abae0 00000027 c000822a
TR =0060 c0316800 000000eb c0008931
GDT=     c02aa820 0000045f
IDT=     c0316000 000007ff
CR0=8005003b CR2=0806ac2c CR3=07fc8000 CR4=00000690
Unsupported return value: 0xffffffff

 5.4-RELEASE-amd64-disc1.iso (FreeBSD, win98 hack disabled) crashes with: 
EAX=00000000 EBX=0002f2c2 ECX=00000008 EDX=000e9e80
ESI=00009e80 EDI=00020000 EBP=00094b6c ESP=00094b68
EIP=000276c6 EFL=00000202 [-------]    CPL=3 II=0 A20=1
ES =0023 0000a000 ffffffff 00cff300
CS =002b 0000a000 ffffffff 00cffa00
SS =0033 0000a000 ffffffff 00cff300
DS =0023 0000a000 ffffffff 00cff300
FS =0023 0000a000 ffffffff 00cff300
GS =0023 0000a000 ffffffff 00cff300
LDT=0000 00000000 0000ffff 00008000
TR =0038 00001f98 00002067 00008900
GDT=     00009690 0000003f
IDT=     00001e00 00000197
CR0=60000011 CR2=00000000 CR3=00000000 CR4=00000000
Unsupported return value: 0xffffffff

 Hope this is helpful to some...


More information about the freebsd-amd64 mailing list