[Fwd: Re: java crashing when load average is high]

Jon Kuster kwsn at earthlink.net
Mon Apr 18 13:58:09 PDT 2005

-----Original Message-----
From: "Ernst W. Winter" <ewinter at ewinter.org>
Sent: Apr 18, 2005 10:51 AM
To: Jon Kuster <kwsn at earthlink.net>
Subject: Re: [Fwd: Re: java crashing when load average is high]

On Mon, 18 Apr 2005, Jon Kuster wrote:

> > > > I am working on getting a new server online.  It is a Dell
> > > > Poweredge with dual HT Xeons and 1GB of RAM.  We are running
> > > > FreeBSD 5.4-RC1 and java 1.4.2_08.
> > > 
> > > Since I'm also helping Toby get this server online, I should
> > > note that we're running the amd64 version of RC1 and the
> > > linux-sun-jdk14.
> > > 
> > You can also use java 1.5 as it compiles and instlls as well
> > works on amd64. I have done a "make isntall clean" on 3 machiens
> > so far, There are some small hitches but you can find it in the
> > newsgroup or mail me directly.
o.k, got it.

> I thought about that, but I haven't been able to get jdk15 to build
> yet.  If you could send me the info about the hitches, that would
> be great.
well I cvsuupped to the latest, which I wuold recoomend first and
then compile the src and kernel and then install it all and then do
the port.

I have:
Copyright (c) 1992-2005 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993,
        The Regents of the University of California. All rights
FreeBSD 5.4-STABLE #2: Thu Apr  7 07:30:15 CEST 2005
    ewinter at lobo.homeunix.org:/usr/obj/usr/src/sys/lobo

> > > FreeBSD ni 5.4-RC1 FreeBSD 5.4-RC1 #0: Thu Apr 14 11:34:58 EDT
> > > 2005 ruessda at ni:/usr/obj/usr/src/sys/NISMP  amd64
> > > 
> > > > I have a java program that reads XML files over an HTTP
> > > > stream and inserts data from them into a mysql database.
> > > > After getting java up and running everything appeared to be
> > > > working normally at first and the program ran fine.  But then
> > > > I tried running it while something else was compiling and the
> > > > load average was up around 5 or 6.  Suddenly the behavior of
> > > > the JVM became extremely erratic.
> > > > 
> > well we had the same problem with a clients machien here,
> > although it was php and mysql, it froze the HD complete and no
> > access possible only switching of the machine.
> The machine remains responsive, it's just that java acts strangely.
Still it could be somehting else as that is what we found out about
it, so have a look with top.

Here the notes I saved:
i had the same problem and solved it executing the last command which
caused the error manually. Looks like the error comes because it's a
very long command. Just put the command that comes between 'then' and
'fi' in a shell file and execute it manually in the directory
work/j2sre/make/java/java (I'm not seating now in my amd64 FreeBSD
computer but I think that was the directory). The compilation will go
on without any problem if you resume it afterwards with a 'make
J.V. Jordan
Try 'make build |& tee build.out' (if your shell is csh or tcsh) or             
'make build 2>&1 | tee build.out' (if sh or bash). After the error              
comes, edit build.out and you will see the command causing it (takes            
about two pages). 

this was in the amd64 grouop a while ago.

you will get also this message:
lobo ewinter 504-->mm .notes/java_compile.txt 
you need to put this in /etc/fstab

 linprocfs   /compat/linux/proc   linprocfs   rw   0  0

 and then, as root, executing the commands:

 kldload linprocfs
 mount /compat/linux/proc 
you would have to fallowing in the kernel too:

options         COMPAT_LINUX32          # for Lunx with i386 ??
options         LINPROCFS               # for Linux 32bit binaries

hoppe that this will be of any use to you. Let me know what will
happen when you find out what it really is?



That gets me farther into the build, but once I restart the build, I eventually end up with 2 javac processes eating as much cpu as they can and not getting anywhere (they ran for more than 10 minutes before I killed them). Once I kill them, 6 more javac's spring to the top of the process list in top.  It's looking more and more like we'll have to either rewrite the app or move to a different OS :/  Got any other ideas?


More information about the freebsd-amd64 mailing list