O. Hartmann ohartman at
Sat Apr 16 04:03:34 PDT 2005

Dag-Erling Smørgrav schrieb:

>Florent Thoumie <flz at> writes:
>>	I have an Asus A8N-SLI (nforce4) Motherboard based box running 
>>	5-STABLE for some time now. Issues are :
>>	x ACPI (quite common),
>ACPI should work.  It's not an issue on the SK8N.  In any case, it's a
>BIOS issue, not a chipset issue.
>If you meant APIC and not ACPI, it should work in mixed mode.  6.0 has
>code which supposedly makes mixed mode unnecessary, but I haven't
>tested it (I don't have a CPU for my SK8N right now)

I have ASUS A8N-SLI Deluxe mobo. BIOS revision is 1006. I have no 
problems with
ACPI. APIC works with NO_MIXED_MODE commented out in kernel. I saw this 
also on RCC3.0 chipsets on some of our servers which are said to be full 
supported (ASUS CUR-DLS,
TYAN Thunder 2500).

>>	x Sound (not much a problem since I have an Emu10K1 based sound 
>>	card which is far better),
>Sound shouldn't be a problem; the nForce audio codec is ICH-compatible
>and should work with snd_ich.  I'm not sure if I ever tested that,

Sound works fine for my installation, no problems with 'stupid' home's 
like watching DVDs (oggle, xine, both using NAS). For lab's purposes 
there is no need
for the AC97 codec sound. On the other hand: in earlier times we avoided 
AC97 sound
and plugged in PCI sound boards. Why should the 'onboard' sound be a 
issue for
a 'don't buy nForce-based motherboards'? Sorry, I don't understand ...

>>	x Network (sk0 works fine, but not should-be-nv0),
>If you're using the nvnet port, that's a known issue.  6.0 has a
>native driver.
This would be a serious "issue" due to the poor PCI32 connection of the sk0
chip, but many guys around here, especially those with DELL/Intel based 
use a kind of Intel PRO1000 based NICs connected to a common PCI32 bus 
and feel
Maybe I lost some glues why sk0 is, for the moment, not a suitable solution.

>>	x USB (no clue, I'm not using it ATM but firewire works).
>USB worked fine on my SK8N - well enough for keyboards, mice and
>memory sticks, anyway.
USB also works fine for me. I tried a Canon digital camera, USB stick, a 
(taken from a DELL Optiplex G280) and a mouse (Logitech USB mouse, only for
some testing purposes). Worked well for me, no problems.

I should mention that I use FreeBSD 5.4-STABLE as cvsupdated today the 
last time
and tested the above mentioned stuff with 5.4-BETA when it came up.

The only point I would complain about is the still 'GENERIC' 
SATA150/SATA300 (switched back to UDMA33)
controller of the nForce4 chipset, but as DES answered me on a prior 
posting this is due to a too fresh

In many aspects for new hardware, FreeBSD is still my first choice. We 
utiliye many Linux systems around here and I can watch what kind of 
problems arize (and aroze in the past) with several SuSE distributions 
on new hardware! Maybe this is a more BSD-patheic statement, but 
sometimes you need to watch the scenario from the point of view of a 
simple customer and user ...


More information about the freebsd-amd64 mailing list