amd64 port of transcode broke

Chuck Robey chuckr at
Wed Apr 13 13:38:47 PDT 2005

Sean McNeil wrote:
> On Wed, 2005-04-13 at 20:06 +0000, Chuck Robey wrote:
>>The port of multimedia/transcode is busted.  That won't surprise you 
> Actually, from your error below it is not transcode that is busted, but
> your libXaw.
>>unduly, but the error is one I would very much like to learn about, so 
>>if you can help, please please do.  The error from the build listing (I 
>>always capture build listings) is:
>>/bin/sh /usr/local/bin/libtool13 --mode=link cc  -Wall 
>>  -fno-strict-aliasing -pipe  -L/usr/local/lib -L/usr/X11R6/lib -o 
>> -rpath /usr/local/lib/transcode -modu
>>le -avoid-version filter_subtitler.lo load_ppml_file.lo load_font.lo 
>>frame_list.lo object_list.lo x11.lo text_processing.lo
>>  load_pictures.lo parser.lo external_programs.lo color_processor.lo 
>>-L/usr/X11R6/lib -lSM -lICE -lXext -lX11  -lXpm -lXaw -
>>lXt -lm -L/usr/local/lib -Wl,--rpath -Wl,/usr/local/lib -lfreetype -lz 
>>-L/usr/local/lib -liconv  -liconv -lm -lz
>>rm -fr .libs/ .libs/filter_subtitler.* 
>>cc -shared  -Wl,--rpath -Wl,/usr/local/lib/transcode 
>>filter_subtitler.lo load_ppml_file.lo load_font.lo frame_list.lo obje
>>ct_list.lo x11.lo text_processing.lo load_pictures.lo parser.lo 
>>external_programs.lo color_processor.lo  -L/usr/local/lib -
>>L/usr/X11R6/lib -lSM -lICE -lXext -lX11 -lXpm -lXaw -lXt -lm -lfreetype 
>>-lz -liconv -liconv -lm -lz  -Wl,-soname -Wl,filter
>> -o .libs/
>>/usr/bin/ld: /usr/X11R6/lib/libXaw.a(Simple.o): relocation R_X86_64_32 
>>can not be used when making a shared object; recompi
>>le with -fPIC
>>/usr/X11R6/lib/libXaw.a: could not read symbols: Bad value
>>gmake[3]: *** [] Error 1
> You are missing a shared library.  It should have picked up,
> not libXaw.a.  You should reinstall the port that has libXaw - for me, I
> use xorg-libraries-6.8.2.  The file(s) should
> be /usr/X11R6/lib/*.  Check that they exist and have proper
> symlinks.

Well, yes and no.

You got it right, I had some funny business, and a bad link to, so I went into /usr/X11R6/lib and fixed it up, then 
reinit'ed ldconfig, and checked it with ldconfig -r, it's all right now. 
  There IS a libXaw.a.  Unfortunately, you don't get a prize for being 
right, because after that, I cleaned it up to start from scratch, and 
the EXACT same error pops up.

> This is an error indicating that you are mixing PIC and non-PIC code
> together.  Everything that goes into a shared library for amd64 needs to
> be compiled -fPIC, but libXaw.a is not built that way.

Well that's fascinating, any notion where you got that info?

As an experiment, I will go ahead and use the /usr/ports/x11/libXaw port 
to reinstall libXaw again.

> Cheers,
> Sean

More information about the freebsd-amd64 mailing list