snd_ modules disconnected from build in 5.3-BETA4

Shaun Jurrens shaun at
Sat Sep 18 07:28:58 PDT 2004


just installed from the 5.3-BETA4-amd64 iso and cvsup'd and upgraded,
etc...  There are just a few nits, I guess.  The sound modules are/were
not installed and could not be built with the sys/modules/Makefile in 
RELENG_5 .  I grabbed 

$FreeBSD: /repoman/r/ncvs/src/sys/modules/Makefile,v 1.397 2004/08/30
03:37:36 scottl Exp $

and had to comment out the aac_ stuff (don't remember the error, but I may
not even have the code to build that module anyway). The snd_via8233.ko 
then built with the other modules, loaded (manually, after boot), and seems
to be working without problems. Is this an oversight from re@ ?

I probably should comment that NOTES makes no mention at all of 'device
sound' either, fwiw.  I didn't see that in the i386 NOTES either, nor in 
GENERIC, but I can't remember if that supposed to be in GENERIC or not.

The only other problem I ran into was that some freetype lib was missing
from the xorg libs pkg (I installed from via pkg, just to get things
up and moving), so I rebuilt that via ports and things just worked.

Good work, guys!  

I could really use the asr driver, btw, but the job looks a little hairy. 
I'll see what I can make out of what's left.

FreeBSD dakota 5.3-BETA4 FreeBSD 5.3-BETA4 #1: Sat Sep 18 15:12:28 CEST
2004     root at dakota:/usr/obj/usr/src/sys/DAKOTA64  amd64

Yours truly,

Shaun D. Jurrens
shaun at

More information about the freebsd-amd64 mailing list