Tyan S4882 vs [5.2.1,5.3-BETA1]

Ketrien I. Saihr-Kesenchedra ketrien at error404.nls.net
Wed Sep 1 22:07:34 PDT 2004

I was working on this with obrien@ earlier this week, but he seems to have 
vanished. And in the meantime, I'm getting nowhere fast.
First off, the nitty gritty. Board's a Tyan S4882, BIOS 1.0.0 and 1.0.2 
attempted. (Tyan support implied that NUMEROUS bugfixes were implemented in 
1.0.2.) Four 848's. Eight 1GB PC3200's from ATP, 2 per CPU. LSI Ultra320-0 
in PCI-X 4 (ZCR.) No, this is not my first Opteron nor is it my first quad. 
This is just being a real pain about it.

So, 5.2.1-RELEASE. You know the caveats - no ACPI, and it boots. Don't 
leave sysinstall sitting or install more than base, the box will panic(). 
Don't even think about walking away, it'll panic(). It's enough to get 
started though. Install base, drag down the rest, everything is happy. 
Except for this system. It's good for one boot off the drive, then:
ffs_mountroot: can't find rootvp
Every time without fail. Boot from CD, verify that the disk is intact, try 
again, and still can't find rootvp. The system also panics once >1GB of 
memory is used, ie; buildworld. vm_fault: fault in nofault entry, presuming 
you've booted it. At this point, I've written off 5.2.1-RELEASE because of 
the vm_fault panic()s.

5.3-BETA1 has been a real nightmare. I tried it per obrien's 
recommendation. Bad idea. ata is instant unusable panic (0xdeded...) and 
the same for acpi, but that's expected. So I set up a PXEboot environment 
using the 5.3-BETA1 miniinst. It boots. It installs. It panic()s if you 
don't watch the install carefully. (sysinstall also likes to down bge0 for 
no reason, but that's a story for another time.) I get it installed. It 
boots consistently, no more ffs_mountroot woes. However, it won't go past 
init. Just locks hard. Can't enter debugger, can't NMI, it's just plain 
locked. I can reproduce it consistently.

I've gone through every possible BIOS setting. Onboard IDE and SATA are 
disabled. I've flipped every setting possible. ccNUMA, Bank Interleave, 
HPET on and off, you name it, I have tried it. Nothing changes. It just 
locks hard.

Any suggestions? I am completely stumped at this point. Everything I've 
tried so far is just getting me back to the same places - panic()s or locks.

Ketrien I. Saihr-Kesenchedra
"I watched the Indy 500, and I was thinking that if they left earlier they 
wouldn't have to go so fast." -Steven Wright 

More information about the freebsd-amd64 mailing list