Problems with 4GB and 5.3 on amd64

Michael R. Wayne amd64 at
Thu Nov 4 23:54:01 PST 2004

Loaded 5.3RC2 from the iso onto my new 4GB dual Opteron server
today.  After getting cvsuop installed, I got 5.3-RELEASE and did
a buildworld.

It never completed: repeating it several times resulted in random
crashes in various places throughout the build.

A bit of googling suggested adding a line to /boot/loader.conf

This permitted the buildworld to complete so I built a new kernel
using the following config file:

   include         GENERIC
   options         SMP
   options         VM_KMEM_SIZE_MAX=(400*1024*1024)

Leaving the 2G line in loader.conf, I managed to complete the entire
build/install process normally.  SMP seems to work properly as well.

I removed the 2G limit from loader.conf and tried several more
buildworlds and the random crashes returned.  A bit of googling
suggested adding the following to /etc/make.conf:

   CFLAGS= -O -pipe -g -DKVA_PAGES=512
   COPTFLAGS= -O -pipe -DKVA_PAGES=512

This had no effect, the random crashes continue during buildworlds.

I tried raising the limit to 3G and the crashes returned.

Any suggestions as to how to proceed would be greatly appreciated.

/\/\ \/\/

More information about the freebsd-amd64 mailing list