Installing a new system....

Willem Jan Withagen wjw at
Tue May 11 16:48:49 PDT 2004

----- Original Message ----- 
From: "Peter Wemm" <peter at>
> On Thursday 06 May 2004 10:16 pm, Joe Fenton wrote:
> > Willem Jan Withagen wrote:
> > >>>When thing go as planned I'm getting my dual opteron system this
> > >>> week. So it is time to start planning....
> > >>>
> > >>>What I'm wanting to dump on it:
> > >>>    FBSD AMD64
> > >>>    FBSD i386
> > >>>    Win2K i386
> > >>>    Win2k x86_???? Beta
> > >>>perhaps
> > >>>    linux-amd64
> > >>>(note it has a 200Gb disk)
> > >>>
> > >>>What bootmanager should I use.
> > >
> > >Anybody tried LILO for these kinds of excercises??
> >
> > I have Windows XP Pro on drive 0, partition 0, XP64 on drive 0,
> > partition 1, and Fedora Core 2 Test 3 x86-64 on drive 1.
> >
> > I have GRUB set to boot them, but remember to go into the BIOS
> > and set the Windows drive to LBA mode (if it's on AUTO) or GRUB
> > won't boot Windows. If you tell GRUB to boot Windows and it just
> > sits there, that's probably the problem.
> >
> > The FreeBSD booter didn't have this trouble. Seems to be a
> > limitation in GRUB. I haven't tried LILO.
> It has been ages since I've messed with grub, but there is one thing 
> that I'd like to make sure is well understood.  With FreeBSD on amd64, 
> there is a very strong symbiotic relationship between loader and the 
> kernel.  A lot more work is done in loader on amd64 than is done on 
> i386.  There is no chance that grub etc will be able to boot an amd64 
> kernel directly.
> Of course, if grub boots the loader, then it should be ok.  But you 
> can't get loader out of the loop.
> This might not be directly relevant to the discussion here, but I wanted 
> to mention it while I thought of it.

I hate to give you the credits for this, but your prevision seems to be right.
If I use GRUB without menu, I can get it to boot FBSD-amd64 just fine.
With the following 'menu' it does not:
default 0
timeout 10

# For booting FreeBSD
title  FreeBSD/i386
root   (hd0,0,a)
kernel /boot/loader

# For booting FreeBSD
title  FreeBSD/AMD64
root   (hd0,2,a)
kernel /boot/loader

# For booting Windows NT or Windows95
title Windows 2000
root        (hd0,1)
chainloader +1
# For loading DOS if Windows NT is installed
# chainload /bootsect.dos

It boots the i386 perfectly.
Now the difference is:

the BTX-loader complains about not finding:

and later on it remarks:
    Can't work out which disk we are booting from.
    Guessed biosdevice 0xffffffff not found by probes
        defaulting to disk0

Any hints as to where to look for a solution?

Note that even Win2K boots find, some of it serves it purpose.


More information about the freebsd-amd64 mailing list