amd64/67745: boot fails on compaq presario r3000z

Jung-uk Kim jkim at
Wed Jul 7 15:24:23 PDT 2004

On Wednesday 07 July 2004 05:36 pm, george+freebsd at wrote:
> The patch below also works wonders on a Compaq Presario R3120US. 

Welcome to the club. :-)

> I've noted the following information in attempting to bring this
> computer up under FreeBSD.

---- >8 --- SNIP!!! --- 8< ---

> ACPI has to be disabled; otherwise, the keyboard and touch pad do
> not work.

Correct.  Keyboard controller probing fails.  Linux people worked 
around it by loading the keyboard driver from a module, not from a 
kernel.  See 'Keyboard Lockup?' from the following link:

Unfortunately, we cannot do that.  I am still hunting for the root 
cause of this problem.

> The processor in this machine apparently does not qualify as an
> AMD64, as an amd64 kernel will not boot.  I could get the exact
> error if anyone cares.

FreeBSD/amd64 5.2-CURRENT works with the following config:

# Make an SMP-capable kernel by default
#options        SMP             # Symmetric MultiProcessor Kernel
# Workarounds for some known-to-be-broken chipsets (nVidia 
device          atpic           # 8259A compatability
#options        NO_MIXED_MODE   # Don't penalize working chipsets

> So far, I have not been able to get XFree86 to work.  The public
> domain NVidia driver does not understand a width of 1280 with a
> height of 800.  With a width of 1280 and a height of 1024, X comes
> up, missing the top 112 rows and the bottom 112 rows of pixels, and
> when I leave X, the display cannot return to text mode
> successfully, showing instead a vertically rolling blur. server works with the following config:

Section "Modes"
        Identifier "16:10"
        # 1280x800 @ 60.00Hz (GTF) hsync: 49.68kHz; pclk: 83.46MHz
        ModeLine "1280x800" 83.5 1280 1344 1480 1680 800 801 804 828

Section "Monitor"
        Identifier      "WXGA LCD"
        UseModes        "16:10"
        HorizSync       30-90
        VertRefresh     50-75

This mode line is from the following link:

I heard other modes also worked but I haven't tried.  One caveat is it 
corrupts console screen as you discribed, which is known problem for 
the open source driver.

> I'll be trying the closed source NVidia driver soon to see if this
> helps.

I had no luck with the nVidia driver.  Someone said that he had better 
luck with the first driver (1.0-3203).

Good luck,


> -- George Mitchell

More information about the freebsd-amd64 mailing list