VESA driver in X

Peter Wemm peter at
Sun Feb 8 18:21:15 PST 2004

On Wednesday 14 January 2004 02:57 pm,  wrote:
> Quoting "Greg J." <xcas at>:
> > techsupport at wrote:
> > > Anyone know why there is no VESA driver in XFree86, or when one
> > > will be available? That's the only one that I can get working
> > > with my Radeon 9800
> >
> > (in
> >
> > > the i386 build). The VGA driver is not usable.
> > >
> > > -Jem
> >
> > My 9800Pro works fine on my FreeBSD/amd64 machine with XFree86
> > 4.3.0's vesa driver. I'm not quite sure what you're asking.
> >
> > Section "Device"
> > 	Identifier	"Card0"
> > 	Driver		"vesa"
> > 	VendorName	"ATI"
> > 	BoardName	"Radeon 9800 Pro"
> > 	BusID		"PCI:1:0:0"
> > EndSection
> 	I solved it -- the XFree86 package somehow doesn't include some of
> the video driver modules. Removing the package and installing from
> ports gave me the ability to use the VESA driver.

I know this is a bit late, but this was my mistake.  I missed a #ifdef 
in the early porting that caused the int10 interpreter to be left out.  
At the time you ran into trouble, the package was still old, but the 
port has been fixed.  The next time the packages are built (if not 
already), they'll get the int10 module.

BTW; I think I ran into this because I used a matrox g450, which was a 
pure MMIO native driver.  It didn't even catch the fact that I forgot 
to enable inb/outb access via /dev/io. mga was probably the only driver 
that would work at that point. :-)

Peter Wemm - peter at; peter at; peter at
"All of this is for nothing if we don't go to the stars" - JMS/B5

More information about the freebsd-amd64 mailing list