advocacy/79860: [maintainer-update] devel/ocaml-pcre : change dependancy to pcre-utf8

Marwan Burelle <marwan.burelle at lri.fr> marwan.burelle at lri.fr
Wed Apr 13 05:50:21 PDT 2005


>Number:         79860
>Category:       advocacy
>Synopsis:       [maintainer-update] devel/ocaml-pcre : change dependancy to pcre-utf8
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    freebsd-advocacy
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          maintainer-update
>Submitter-Id:   current-users
>Arrival-Date:   Wed Apr 13 12:50:20 GMT 2005
>Closed-Date:
>Last-Modified:
>Originator:     Marwan Burelle <marwan.burelle at lri.fr>
>Release:        FreeBSD 5.4-PRERELEASE i386
>Organization:
>Environment:


System: FreeBSD 5.4-PRERELEASE #0: Thu Mar 17 19:10:49 CET 2005
    root@:/usr/home/obj/usr/src/sys/KER_pc5-179



>Description:


Many ocaml programs assume pcre is built with utf8 support, so I change the dependancy to the slave port of pcre with utf8 enabled.


>How-To-Repeat:





>Fix:


--- diff-ocaml-pcre begins here ---
diff -ruN ocaml-pcre.orig/Makefile ocaml-pcre/Makefile
--- ocaml-pcre.orig/Makefile	Wed Apr 13 13:49:46 2005
+++ ocaml-pcre/Makefile	Wed Apr 13 14:16:54 2005
@@ -17,7 +17,7 @@
 
 BUILD_DEPENDS=	ocamlc:${PORTSDIR}/lang/ocaml \
 		ocamlfind:${PORTSDIR}/devel/ocaml-findlib
-LIB_DEPENDS=	pcre.0:${PORTSDIR}/devel/pcre
+LIB_DEPENDS=	pcre.0:${PORTSDIR}/devel/pcre-utf8
 
 USE_GMAKE=	yes
 MAKE_ENV=	OCAML_LIB_INSTALL="${PREFIX}/lib/ocaml/site-lib/pcre" \
--- diff-ocaml-pcre ends here ---



>Release-Note:
>Audit-Trail:
>Unformatted:


More information about the freebsd-advocacy mailing list