Now here's something for FreeBSD advocacy

Daniel Rudy dr2867 at
Thu Aug 5 02:31:44 PDT 2004

FreeBSD does it again.

I'm taking an older computer and making it into a lightweight server for
various uses.  Things like usenet, email, ftp, and web.  The motherboard
is a FIC VA-503+ v1.2.  The CPU is a AMD K6-2 at 500MHz and 128MB Ram.
It has a 13.6GB primary harddisk as well.  All of this is in a full
tower AT case with a 300W power supply.  For my personal use, it's a
decent system.  Oh, and I'm using FreeBSD 4.10R.

Well, for the server functions, I needed to add another harddisk into
the system.  I went out and got a Maxtor 80GB harddisk and installed it
into the system.  Then I went into the BIOS to tell the computer about
the harddisk, and when the BIOS tried to calculate the size of the disk,
it would hang the system.  I couldn't even boot.  So, I set the drive
type to NONE, and let the system boot up into FreeBSD.  I was going to
take the computer back apart and install a special IDE controller card
that I had laying around for just this type of incident.

On the kernel boot, guess what I saw...My new harddisk.  I was stunned.
 After I recovered from my shock, I started up sysinstall.  It took the
fdisk, disk label, and newfs with no complaints.  I added the entry to
/etc/fstab and then rebooted.  Drive is still there and mounted, ready
for use.

Using an older motherboard (AT form factor (not ATX) made in 2000) which
there are no more BIOS updates being made (Last one is in the ROM), with
a newer harddisk that the BIOS crashed when it tried to probe it,
FreeBSD took the drive directly at the hardware level and used it with
no problems.

Kudos to the FreeBSD development teams.
Daniel Rudy

More information about the freebsd-advocacy mailing list