cvs commit: src/usr.bin/top machine.c src/lib/libkvm kvm_proc.c src/bin/ps extern.h keyword.c print.c ps.c src/sys/kern init_main.c kern_exit.c kern_idle.c kern_intr.c kern_kthread.c kern_shutdown.c kern_thread.c sched_4bsd.c src/sys/sys kthread.h ...

Julian Elischer julian at
Fri Oct 26 09:01:51 PDT 2007

John Baldwin wrote:
> On Friday 26 October 2007 04:00:41 am Julian Elischer wrote:
>> julian      2007-10-26 08:00:41 UTC
>>   FreeBSD src repository
>>   Modified files:
>>     usr.bin/top          machine.c 
>>     lib/libkvm           kvm_proc.c 
>>     bin/ps               extern.h keyword.c print.c ps.c 
>>     sys/kern             init_main.c kern_exit.c kern_idle.c 
>>                          kern_intr.c kern_kthread.c 
>>                          kern_shutdown.c kern_thread.c 
>>                          sched_4bsd.c 
>>     sys/sys              kthread.h proc.h 
>>   Log:
>>   Introduce a way to make pure kernal threads.
>>   kthread_add() takes the same parameters as the old kthread_create()
>>   plus a pointer to a process structure, and adds a kernel thread
>>   to that process.
>>   kproc_kthread_add() takes the parameters for kthread_add,
>>   plus a process name and a pointer to a pointer to a process instead of 
> just
>>   a pointer, and if the proc * is NULL, it creates the process to the
>>   specifications required, before adding the thread to it.
>>   All other old kthread_xxx() calls return, but act on (struct thread *)
>>   instead of (struct proc *). One reason to change the name is so that
>>   any old kernel modules that are lying around and expect kthread_create()
>>   to make a process will not just accidentally link.
>>   fix top to show  kernel threads by their thread name in -SH mode
>>   add a tdnam formatting option to ps to show thread names.
>>   make all idle threads actual kthreads and put them into their own idled 
> process.
>>   make all interrupt threads kthreads and put them in an interd process
>>   (mainly for aesthetic and accounting reasons)
>>   rename proc 0 to be 'kernel' and it's swapper thread is now 'swapper'
>>   man page fixes to follow.
> Why not just "idle" and "intr" for the kernel processes?  We didn't 
> have "swapperd", "syncerd", or "vnlrud" before.

no reason.. I spent a whole 2 seconds thinking abut the names.

"your wish is my command" :-)


More information about the cvs-src mailing list