cvs commit: src/sys/ddb db_command.c db_thread.c src/sys/vm vm_object.c vm_pageout.c src/sys/i386/i386 pmap.c src/sys/i386/ibcs2 ibcs2_sysvec.c

John Baldwin jhb at
Wed Jan 17 16:08:32 UTC 2007

On Wednesday 17 January 2007 10:05, Xin LI wrote:
> delphij     2007-01-17 15:05:52 UTC
>   FreeBSD src repository
>   Modified files:
>     sys/ddb              db_command.c db_thread.c 
>     sys/vm               vm_object.c vm_pageout.c 
>     sys/i386/i386        pmap.c 
>     sys/i386/ibcs2       ibcs2_sysvec.c 
>   Log:
>   Use FOREACH_PROC_IN_SYSTEM instead of using its unrolled form.

I actually think this macro is actually not that useful and I'd rather
we get rid of it. :)  For one thing zombies are still processes and this
doesn't cover those, so the name is a bit misleading.  However, this is a 
minor thing, and I can see that the kernel should be consistent one way or 
another.  I'd just vote for being consistent by removing FOREACH_PROC and 
FOREACH_THREAD.  The kernel doesn't use wrappers for other lists, it just 

John Baldwin

More information about the cvs-src mailing list