cvs commit: src/sys/kern kern_mbuf.c sys_pipe.c sysv_msg.c sysv_sem.c sysv_shm.c uipc_mbuf.c uipc_socket.c uipc_socket2.c uipc_syscalls.c src/sys/sys socketvar.h sysctl.h

Robert Watson rwatson at
Sat Jun 10 21:39:31 UTC 2006

On Sat, 10 Jun 2006, Andrew R. Reiter wrote:

> :  After this change, socket allocation and deallocation is entirely
> :  centralized in one file, and uipc_socket2.c consists entirely of socket
> :  buffer manipulation and default protocol switch functions.
> Any thoughts on modifying file name of uipc_socket2.c to something more 
> consistent with the contents of the file?
> Thanks for your hard work.

Yes -- I've loosely been thinking that the pru_ entries should move to 
uipc_domain.c or something similar, and then uipc_socket2.c can be renamed to 
uipc_sockbuf.c.  Need to look in detail at what's left, and where to move it.

Robert N M Watson

More information about the cvs-src mailing list