cvs commit: src/sys/kern kern_prot.c src/sys/sys systm.h

Robert Watson rwatson at
Mon Jul 19 07:29:08 PDT 2004

On Mon, 19 Jul 2004, John Baldwin wrote:

> On Friday 16 July 2004 05:44 pm, Colin Percival wrote:
> > At 12:42 16/07/2004, John Baldwin wrote:
> > >On Friday 16 July 2004 11:57 am, Colin Percival wrote:
> > >>   Log:
> > >>   Add a SUSER_RUID flag to suser_cred.  This flag indicates that we want
> > >> to check if the *real* user is the superuser (vs. the normal behaviour,
> > >> which checks the effective user).
> > >
> > >Could we rename PRISON_ROOT to SUSER_PRISONOK or some such to be
> > > consistent?
> >
> > I'd be happy to do this; should I simply add the new name, or should I
> > make the substitution across the entire tree?
> I would ask Robert's opinion. :)  I would vote for adding the new name
> and changing it across the tree and add in a #define for the old name
> that is inside #ifdef OBSOLETE_IN_6 or some such so it is deprecated for
> 5.x and gone in 6.0. 

I think it would be reasonable to even remove the old name for 5.x -- it's
fairly unusual for device drivers, etc, to need to know about Jails, and
we've already changed the API for super user checks between 4.x and 5.x
anyway.  I'd be willing to go with the flag change across the entire tree
(as long as it's done carefully :-).

Robert N M Watson             FreeBSD Core Team, TrustedBSD Projects
robert at      Principal Research Scientist, McAfee Research

More information about the cvs-src mailing list