cvs commit: src/sys/dev/if_ndis if_ndis.c

Niki Denev nike_d at
Wed Apr 21 11:15:28 PDT 2004

Bill Paul writes:

>> doesn't seem to help here.... i got exactly the same lockup after the first 
>> packets transmitted/recvd over the wireless as before...
>> the machine is ibm tp X31, with the above mentioned centrino wireless mini 
>> pci card, and -current as from 1-2 hours ago.
>> is there any info that i can provide, to help on this?
>> --niki
> Well, seeing as how you didn't provide any info at all in this e-mail,
> what do you think?
> I really wish people would stop asking questions like this and just
> offer me the information. It's not like you need me to lay it all out
> for you. There isn't anything magical or complicated that requires any
> hand-holding my my part. Just show me how to reproduce your problem.
> Now, notice: I said _SHOW_, not _TELL_. Don't describe the problem
> or interpret the problem. Just show me the precise sequence of steps
> which you take that precipitates the problem. And don't summarize.
> Saying "I just bring the interface up" is not helpful. Saying "I
> use ifconfig to bring the interface up, and here's the commands I
> typed and all the error/console messages I saw" is helpful. You want
> to show me the minimum number of steps I need to take to reproduce
> the issue. And you don't want to assume anything or skip a step
> because you think it's trivial or unimportant.
> Oh, and somewhere along the line, you're going to forget that I can't
> see what kind of network you're attached to (ad-hoc? bss?) and what
> kind of AP, if any, that you're connected to (manufacturer? model?),
> so I'm warning you right now _NOT_ to do that. You're also going to
> forget to give me a copy of the exact driver that you're using, so
> I'm going to caution you against that as well.
> -Bill
> --
> =============================================================================
> -Bill Paul            (510) 749-2329 | Senior Engineer, Master of Unix-Fu
>                  wpaul at | Wind River Systems
> =============================================================================
>               <adamw> you're just BEGGING to face the moose
> =============================================================================
> _______________________________________________
> cvs-src at mailing list
> To unsubscribe, send any mail to "cvs-src-unsubscribe at"


i run -CURRENT as of less than hour.
kernel config and dmesg on :

i'm using an openbsd 3.4-stable with Linksys wmp11 (prism2.5 ISL3874A,
firmware 1.0.5 pri, 1.3.1 station) as AP. 
i'm also preloading ndis.ko in loader.conf
the windows driver files are w70n51.inf and w70n51.sys, 
and also are available on the above URL

after the buidlworld/buildkernel/installkernel/reboot/installworld/reboot 
i do:

# cd /sys/modules/if_ndis
# make clean
# ndiscvt -s w70n51.sys -i w70n51.inf -o ndis_driver_data.h
# make
# make load
/sbin/kldload -v /usr/src/sys/modules/if_ndis/if_ndis.ko
pci0: driver added
pci0:31:3: reprobing on driver added
pci0:31:6: reprobing on driver added
pci1: driver added
pci2: driver added
pci2:2:0: reprobing on driver added
ndis0: <Intel(R) PRO/Wireless LAN 2100 3B Mini PCI Adapter> mem 0xc0200000-0xc02
00fff irq 11 at device 2.0 on pci2
ndis0: Reserved 0x1000 bytes for rid 0x10 type 3 at 0xc0200000
can't re-use a leaf (ESS_ID)!
ndis0: NDIS API version: 5.1
ndis0: Ethernet address: 00:04:23:92:33:23
ndis0: 11b rates: 11Mbps 2Mbps 1Mbps
Loaded /usr/src/sys/modules/if_ndis/if_ndis.ko, id=9
# ifconfig ndis0 ssid my_accpnt wepmode on 0x**************************
# ifconfig ndis0 netmask up
ndis0: set filter failed: 6
ndis0: set filter failed: 6
ndis0: set filter failed: 6
ndis0: link up

after this i have a few seconds before total freeze,
but it seems like any network activity is freezing the machine immediately.
if i ping it from other machine, it responds exactly to one ping, and then 

sorry for the lack of information in my previous post, but i was under the 
impression that the problem is well known, and i was just reporting that it 
is still not working after the last change.
i hope that this info will help.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the cvs-src mailing list