cvs commit: src/sys/kern subr_turnstile.c src/sys/sys turnstile.h

John Baldwin jhb at
Tue Apr 6 12:09:34 PDT 2004

jhb         2004/04/06 12:07:21 PDT

  FreeBSD src repository

  Modified files:
    sys/kern             subr_turnstile.c 
    sys/sys              turnstile.h 
  Rename turnstile_wakeup() to turnstile_broadcast() to make the naming
  more consistent with other APIs. sleepq and cv's use signal/broadcast, and
  msleep uses wakeup_one/wakeup.  Prior to this turnstiles were using a
  signal/wakeup mixture.
  Revision  Changes    Path
  1.142     +2 -2      src/sys/kern/subr_turnstile.c
  1.3       +3 -3      src/sys/sys/turnstile.h

More information about the cvs-src mailing list