Re: mesa-libs conflicts with libglvnd?

From: tech-lists <tech-lists_at_zyxst.net>
Date: Sun, 20 Jun 2021 00:52:51 +0100
Hi,

On Fri, Jun 18, 2021 at 05:36:19PM +0200, Christoph Moench-Tegeder wrote:
>## Robert Huff (roberthuff_at_rcn.com):
>
>> 	Updating mesa-libs this morning, I get:
>
>UPDATING 20210617
>
>Regards,
>Christoph

I read that in UPDATING, but found a problem when I tried to rebuild
x11/nvidia-driver, which is seemingly related (nvidia-driver builds
libglvnd as a dependency):

[...]

# make install
===>  Installing for libglvnd-1.3.3
===>  Checking if libglvnd is already installed
===>   Registering installation for libglvnd-1.3.3
Installing libglvnd-1.3.3...
pkg-static: libglvnd-1.3.3 conflicts with nvidia-driver-460.80 (installs
files into the same place).  Problematic file: /usr/local/lib/libGLX.so
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/graphics/libglvnd
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/graphics/libglvnd
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/x11/nvidia-driver
*** Error code 1

Stop.
make: stopped in /usr/ports/x11/nvidia-driver

[...]

# pkg info -xo mesa
mesa-dri-20.2.3_1              graphics/mesa-dri

Shall I make a PR for graphics/libglvnd or x11/nvidia-driver or both?

thanks,
-- 
J.

Received on Sat Jun 19 2021 - 23:52:51 UTC

Original text of this message