[Bug 246767] graphics/mesa-libs: enable libglvnd support

From: <bugzilla-noreply_at_freebsd.org>
Date: Thu, 17 Jun 2021 10:37:04 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=246767

--- Comment #21 from Adriaan de Groot <adridg_at_freebsd.org> ---
_at_jbeich, _at_kbowling: given the last comment (number 19) here, can you add an
UPDATING telling people to uninstall previous relevant things before
re-building. This is a common stumbling block for portupgrade-users -- and not
one that poudriere+pkg users are likely to notice in testing.

This change has a positive -- probably unexpected -- side-effect on CMake-users
that look for OpenGL: now GLVND is found, EGL is made available as an imported
target. The relevant CMake-module is
/usr/local/share/cmake/Modules/FindOpenGL.cmake and talks about how GLVND is
Linux-only (which is now no longer true, it seems). In turn, this fixes some
build problems with KDE Plasma (which would really like to use EGL but couldn't
find it correctly on FreeBSD before).

-- 
You are receiving this mail because:
You are on the CC list for the bug.
Received on Thu Jun 17 2021 - 10:37:04 UTC

Original text of this message