Re: mouse and keyboard fail to work with xorg-server-1.20.11_3,1

From: Alexey Dokuchaev <danfe_at_freebsd.org>
Date: Wed, 21 Jul 2021 08:05:16 +0000
On Fri, Jul 16, 2021 at 08:35:39AM +0200, Gary Jennejohn wrote:
> > ...
> > To clarify things somewhat, I deleted both ports today and then
> > no longer had the mouse and keyboard after starting xorg-server.
> > 
> > Re-installing xf86-input-libinput-0.30.0_1 while keeping
> > kern.evdev.rcpt_mask set to 6 got me back the mouse and keyboard.
> > 
> > Whether using the default of 12 for kern.evdev.rcpt_mask works I
> > haven't tried.  But I have kbdmux in my kernel config file, so I
> > think 6 is the right setting for me.
> 
> Using kern.evdev.rcpt_mask=12 still works, so it was the missing
> xf86-input-libinput-0.30.0_1 which caused my problems.

Another solution is to disable these newish input shenanigans and
just use good ol' xf86-input-keyboard and xf86-input-mouse drivers,
works like a charm for me (and no dances with kern.evdev.rcpt_mask
required).  However, it could be useful to see if this new X.org
input model would fix the regressions in Quake2 movement* I have
reported back in 2017 and which were still unfixed last time I've
tried to play the game.

./danfe

*) https://docs.freebsd.org/cgi/getmsg.cgi?fetch=2288058+0+archive/2017/svn-ports-head/20170924.svn-ports-head
Received on Wed Jul 21 2021 - 08:05:16 UTC

Original text of this message